Issues with testing SFX with Lightroom Classic and Photoshop

This issue report is a consequence of tests I did because of this post by @gillesdebda.


  • Downloaded a fresh installer (Nik Collection 4.3.4, according to what the installer advertises)
  • Installed it on my iMac 2019 running macOS Big Sur 11.6.5
  • Tested with a few images, one after the other

Observations I made when testing with Lightroom Classic 11.2

  • LrC takes a fairly long time (several seconds) before even the progress bar appears
  • LrC CPU load is fairly high at 180%, in view of “nothing happening”
  • After several seconds (and this delay increased with every image), the tiff appears
    and Silver Efex launches
  • Saving changes in SFX brings back the results to LrC in a second or two
  • 4 images later, LrC runs at around 700%, but I cannot see anything happening…
  • When I display the 4 images side by side in LrC’s compare view, the last image displays some flickering, sign of LrC doing something. Tried to screen record that flickering, but it then stopped.

Test with Photoshop 23.2.2

  • Everything worked as expected

My conclusion

  • Something is not right in cooperation between LrC and SFX (have not tested other apps)
  • Looks like a new thing that I’ve never had with previous versions of
    macOS, Nik and LrC ← all have changed since my last tests
  • If I get ill effects on Big Sur, the issue is not limited to macOS Monterey as proposed by @gillesdebda

It is exactly that I experience on my MBP 16” M1Pro using Monterey 12.3.
I already open many tickets on DXO support without any solutions …
I think the root cause is Rosetta because NIK is not Apple-Silicon compliant.

So I am waiting for DXO to solve these issues not only with SFX but with all NIK plugins.

1 Like

I’m using a high end 2015 Macbook pro and after some recent releases of Silver Efex Pro, I’m having the same problem. Silver Efex Pro worked fine up to a few months ago.