Lightroom plugin problem

I launch Silver Efex Pro using Lightroom’s “Edit In” menu. When I save in Silver Efex (and it exits) I then return to Lightroom. The image then keeps flashing in Lightroom Classic over and over. Usually slowly. It’s as if Lightroom is struggling to deal with the edited TIFF that Silver Efex produced. Any idea what is going on? If I restart Lightroom everything is then fine, but this is very slow and tedious. I’ve had this problem with version 4.x.x and 5.x.x. I’m on an Apple M1 Mac in case that matters. This problem is 100% reproducible for me and I can create a screen grab video if that is helpful.

I’ve had the same problem after a recent upgrade. SEP is almost unusable because of this slowness.

This is what I just wrote to DXO support. I suggest you open a ticket and let them know…

I have done more testing and this bug is specific to DXO Nik. I believe Nik is outputting TIFF files that trigger this problem in Lightroom Classic.

I can’t find any other 3rd party app that triggers this problem in Lightroom Classic. For example I use multiple Topaz Labs apps and I can immediately enter develop mode after those apps output a TIFF to Lightroom Classic and exit. No waiting 30 seconds to 2 minutes.

Is the engineering team on this ticket? If not I’d like to get them added. This is definitely a case of Nik outputting TIFF files that cause problems with Lightroom Classic.

This problem is 100% reproducible and didn’t exist in previous versions of Nik as far as I remember.

I sent an additional support message today after the Nik 5.2 release…

Nik Collection 5.2 does not fix the problem.

It can still take upwards of 2 minutes for Lightroom Classic to be usable with a TIFF edited using Silver Efex via the “Edit In” menu option at the top of the Lightroom Classic screen. This has been a problem in Nik Collection 4.x and 5.x.

Other 3rd party apps such as Topaz Labs AI apps produce TIFF files that are instantly editable using the same “Edit In” Lightroom Classic feature.

I really think this problem needs to be escalated to your engineers. It is 100% reproducible for me and other people on your forum. If they can reproduce the problem then they can fix it. The problem is likely something to do with your TIFF file format causing issues with Lightroom Classic. Other companies produce TIFF files that don’t have these problems.

1 Like

I’ve just tried v5.2 and it’s still as bad as before. I’m done now. Uninstalled and won’t be using any of their software again.

I have this problem as well. It takes ages for Lightroom to recognize the output from SFX. Usually, I just have an empty area where the photo should be. This seriously affects the usefulness of the software. I am running on an M1 Macbook pro.

I have a support ticket open with Seth from DXO. I’m hoping to get this figured out. I believe my ticket is being sent to engineering. Hopefully Seth sees this and can reply with more details. I’ve told him about the multiple forum posts with people having this same problem. I highly recommend you open a support ticket and reference this forum post.

I too have opened a support ticket but after seeing multiple posts on these forums and elsewhere referring to these problems going back several months I’m afraid I have very little faith in DXO being able or interested in coming up with a fix soon (or at all)

@geoffc60 I feel your pain, but I still have hope DXO will sort it out. I think the key here is to make sure your support tickets get escalated to engineering. The support staff can’t fix this. It’s 100% a problem with the TIFF files that DXO is outputting. These TIFF files are causing LrC to get confused. In a perfect world, Adobe would fix LrC, but we all know that’s not going to happen. DXO needs to either 1) make their TIFF files not trigger this problem in LrC or 2) work with Adobe to sort it out. Adobe is not going to fix this on their own as they don’t care about DXO. It should be 100% possible for a DXO engineer to reproduce the problem and isolate what their TIFF format is doing to cause this.

I am cross linking all the forum threads that are talking about the exact same bug. A lot of people are experiencing this problem: Problems using Silver Efex Pro3 and Viveza with Lightroom

Make enough noise and it will get fixed.

The problem isn’t really Adobe’s to fix. It’s DXO’s

@geoffc60 it’s hard to say. As a software engineer myself… this is what it boils down to:

  1. Does this problem occur only on M1 Macs or also on Intel Macs?
  2. Can DXO figure out what in their TIFF files is causing the problem? I’ve dug into DXO TIFFs a bit and and they are doing some unique things compared to say a TIFF that Photoshop outputs.
  3. Can DXO figure out a workaround so their TIFFs don’t confuse LrC? Hopefully.

DXO being a big company should 100% have a relationship with Adobe. Worst case, DXO should be the ones that open a support ticket with Adobe and work with them to make LrC play nice with their TIFF files.

My concern is that DXO may view this as an Adobe problem and not want to deal with it. My view is that DXO should be responsible for working with Adobe if necessary. It’s not up to us end users to open Adobe support tickets. I am positive that either DXO or Adobe could fix this problem since it boils down to what’s in the TIFF file.

Good news everyone. I’ve been working with DXO support (Seth specifically) on this bug where Lightroom Classic gets stuck on TIFF files generated by Silver Efex (and other Nik apps). They have it fixed and it will be in the next release. Seth & the engineering team have been very helpful.


If this is the case and they have a fix then what on earth are they waiting for? Release the update because my expensive software is unusable. Either that or give me my money back for a defective product.

They fixed two crashes I reported and are working on a third crash I found while testing the first two fixes. I assume they need a bit more time to sort it out. Overall they really have been trying hard to resolve all the M1 Mac crashes.

The latest version (5.2.1) that was just released fixes this problem. Thank you DXO team. Specifically Seth and the engineer(s) that worked on this problem! I specifically tested with Lightroom classic v12.