Just purchased Nik Collection 4 - Viveza 3 not applying edits when pressing apply

Hi. I just purchased Nik Collection 4

I’m installed the collections as plugins into Photoshop. I’m running Photoshop Version 22.4.1 on a 2017 iMac running Mojave 10.14.6 with 40 GB of RAM.

I opened an image in PS and duplicated the background layer.

I went into Viveza and applied a simple edit consisting of a single control point. When I press Apply, the app returns me to Photoshop but the edit is not applied.

I also saw that while in Viveza, if I press the brush button, the same thing occurs. The app immediately returns me too photoshop.

I’m disappointed to see that the very first thing I tried after purchasing doesn’t work.

I hope there is a simple fix.

Your help is greatly appreciated!

Jack K.

This happened to me as well. I am on Windows 10. I can’t remember exactly what I did but I believe I also duplicated the background layer. However, when I tried the same thing again it worked, so there is some bug here.

I’ve found that if I launch the Nik Apps from the Automate / Nik Selective Tool within PS it works.

However, if I select the Nik App from the Filter menu it behaves as I described in my initial post.

Go figure.

I can no longer repeat the behaviour you and I experienced. But I did notice a difference when Nik Collection plugins (I tested Viveza 3, Silver Efex Pro 3, and Color Efex Pro) are launched. When any of these plugins are opened via the Nik Selective tool, a new layer is immediately created in Photoshop. However, if any of these plugins are opened via the Filter menu in Photoshop, the new layer is NOT created. The new layer is not created until the changes are applied in the plug-in. Not sure why the behaviour should be different. I would say as a fail-safe to always use the Nik Selective Tool rather than the Filter menu in Photoshop.


I can’t comment on the (first generation) Selective tool (still on old PS), but it always have been like this.

The moment I apply the Nik Filter (version 3), a duplicate layer with the applied effect is automatically created – except for HDR2 and Perspectiv Effects … so, one has to know.

[ about compatibility problems – see Issues with Nik4 - #8 by Wolfgang ]

I’m running into the same issue where Viveza 3 won’t save or apply any edits. Color Efex works fine.

I’m running a M1 MacBook Air, and then image (.tif) is loaded directly into the Viveza 3. I would try via Photoshop but Nik isn’t compatible with the new photoshop yet…

I’ve tried installing and uninstalling the complete suit. This did not fix the issue.

I’m having the very same problem.

If I launch Viveza from menu Filter, after applying changes, it creates a new layer with no changes at all.

If I launch Viveza from the Nik App it works perfectly. Applies the changes in a new layer.