Issue with DXO files being imported into Lightroom Classic

I have an issue with files processed by DXO PureRaw 4.2.0 and then imported into Lightroom Classic 13.3.

If I import the raw NEF file it imports and uses Process Version 6 (current version). If however I open the NEF file with DXO PureRaw and then try to import the file into Lightroom Classic it imports with the very old Process Version 1 and much of the functionality of Lightroom is lost.

This only happens with Lightroom set to import files with Camera Settings (in preferences > presets > global). If I change this to Adobe Defaults it loads with the correct Process Version 6.

I have been in contact with Adobe and they suggest that this is a bug in DXO PureRaw. They provided the following explanation:

DETAILS

The DXO DNG includes Develop settings, both defining camera defaults for that file and current Develop settings…

When LR imports the file with Global set to Camera Settings, it applies the camera defaults defined in the DXO DNG and then applies the develop settings. It’s this combination of defaults and settings that is setting Process Version to 1, Profile to Adobe Standard, and Detail settings to 0.

After importing, when you click the Reset button, LR resets the develop settings to the camera defaults specified in the file. At this point, Process Version goes to 6 and Profile to Camera Standard,. Also strange is that the file’s camera defaults define various Detail settings: The develop settings define all those to be 0. so when you first import the file they’re all 0, but when you hit Reset to apply the camera defaults defined in the file, they go to the settings above.

I’m not sure what DXO is trying to accomplish here, and whether this is a DXO bug.

Any advice would be appreciated

I’m having exactly the same problem since I update PureRaw to 3.13.0.42. I’m using Lightroom 6.0 (which I know is an old version). Its default colour process is 2012. But the PureRaw dng files now import as 2003 process. It took me a while to figure out why all the sliders were changed! DXO has messed something up with the latest updates of versions 3 and 4 of PureRaw. At least I’ve figured out that I can manually change the files back to process 2012–highlight and hit ctrl-shft-R (reset). But this is a bug that will leave lots of people mystified. Note that I don’t see a preference setting to change the import behaviour in my version of Lightroom.

Opening the raw NEF file in Photoshop and viewing the XMP information in the File Info menu option and selecting Raw Data there is a line entry that says:

     <crs:ProcessVersion>15.4</crs:ProcessVersion>

Opening the file after passing through DXO PureRaw 4.2.0 the line has changed to:

     <crs:ProcessVersion>5.0</crs:ProcessVersion>

I tried turning off all adjustments in PureRaw but got the same entry.
For comparison I tried the noise reduction and optical correction using DXO PhotoLab 7.7.0 and the processed dng imported into Lightroom Classic correctly using Process Version 6. Viewing the XMP data again in Photoshop the line entry stated:

     <crs:ProcessVersion>15.4</crs:ProcessVersion>

i.e. the same as the original raw NEF file.

So it seems that DXO PureRaw is changing the value for the crs:ProcessVersion line entry from 15.4 to 5.0 while PhotoLab 7 doesn’t do this. This seems to instruct Lightroom to apply the earlier process version. As this entry is only read when Lightroom Classic is set to use Camera Settings on import it explains why it doesn’t cause the same problem when importing with Adobe Defaults.

From answer to my post on Adobe forums:

DXO is using the wrong numbering scheme for process version. LR and Camera Raw use an internal numbering scheme for representing process version in their develop settings (what you see in the XMP), while the products display an external numbering scheme in the user interface. Here’s the mapping between external numbering and internal numbering (which I reversed engineered for my Any Filter plugin):

"Version 1",        "5.0",
"Version 2",        "5.7",
"Version 3 (beta)", "6.6",
"Version 3",        "6.7",
"Version 4",        "10.0"
"Version 5",        "11.0"
"Version 6",        "15.4"

So when DXO records crs:ProcessVersion = 5.0, they’re thinking they’re referring to external Version 5 / internal Version 11.0, but in fact they’re getting internal version 5.0 / external Version 1.0.