Incorrect lens identification since 6.5 update

On some images, but not all, DXO Photolab 6.5 falsely identifies my Tamron SP 24-70mm f/2.8 Di VC USD as a Sigma 24-70mm f/2.8 IF EX DG HSM. I do not own, and have never owned, a Sigma 24-70mm lens. So, on some of my images taken with the same lens, on the same day with the same camera body, DXO indicates that the images were taken with a Sigma lens instead of the Tamron lens.

So the lens correction is not correct. DXO wants to download the Sigma Optical Module to use with the Tamron lens, which is unacceptable. This problem did not exist before the latest update, v6.5.

The weird thing is that on some images taken a few minutes apart with the same exact lens/body combination is correctly identified on one image and falsely on the very next image.

I have filed a support ticket, but it is very frustrating because now I have images which I can’t properly process. This problem did not exist (for me) until the v6.5 update.

Hi Bryan. Can you upload an example each of a RAW file that works correctly and one that doesn’t to a file sharing service and post the link here? Then we can try and find the difference.

Hi Mark,

Image 1

Image 2

Both images were taken today with the same camera/lens body combination.
The lens is a Tamron SP 24-70mm F2.8 Di VC USD. In my Windows 11, DXO PL6.5 Image 1 is incorrectly identified as being shot with a Sigma lens. Image 2 is correctly identified as shot with my Tamron lens.

Strange indeed…but you can temporarily “fix” the issue by replacing the module ID in the ZDOPSOURCE table of the database…if you feel comfortable with such interventions and keep an unaltered database backup…


The two entries in blue were empty because DPL was unable to identify the lens correctly.
I copied the entries from the files that listed the module, saved the DB and the issue was gone.
Caveat: Re-indexing the folder(s) and possibly other actions reset the modifications.

@bconner, google asks for a login. Could you make the files publicly available temporarily?

Ooops…it is fixed now. You should be able to view/download the files now.

Downloaded the image files successfully. Thanks!

Looked at metadata entries and see no difference in whatever comes up under “lens”

Notice that lens info is fairly shaky in the EXIF section…and that several lenses are “offered” according to what ExifTool finds in the files. I presume that the files I downloaded have not been edited by any other app.

Note that ExifTool lists lens info in clear text, while it’s mostly encoded as a numerical value.

Full tag extracts can be found in this file: (13.6 KB)

Interesting case… :exploding_head:

For the sake of “science”, since I still had the images on the sd card, here they are directly from the card.

They haven’t been opened in any program.

Image 1 card copy
Image 2 card copy

1 Like

Yeah, it is a strange situation indeed. Especially since everything was fine until the v6.5 update yesterday. I have been using this same exact Tamron lens for over 2 years and PhotoLab has always correctly identified it. But I do vaguely remember that maybe in an earlier version of PL that it asked me which lens to choose, either the Sigma or the Tamron. I do remember for sure that when I was using the lens on a 6d body, both Michael Tapes’ Focus Tune app and Reikan FoCal misidentified the lens as well. But, that didn’t have an effect on anything except the wrong lens name some place.

With PhotoLab 6.5 I am not able to use the correct lens module, which definitely reduces the value of PL6.5 in my opinion.

This possibility to manually resolve lens ambiguities went away with a revised lens recognition algorithm that has not improved the situation imo. I posted about it a while ago, but things have not improved since then.

Feature request:

This is a very strange phenomenon. In PL6.5, the rose pic only allows the Sigma option but the pic of the lady offers either Sigma or Tamron. Interestingly, if I chose to download the Sigma profile then the pic of the lady no longer shows a choice. If I download the Tamron profile first for the lady then the rose still needs the Stigma profile.

I went through the EXIF(and other supplied data) line by line and the only differences that I found were photo-specific. Everything else was Identical. I have no idea what could possibly trigger PL6.5 to choose the Sigma for one photo and give a choice for the other photo. I think that a support ticket at is definitely in order.

1 Like

same here – and for this pic
still get this message
Screen Shot 04-16-23 at 12.29 AM

( check on “Apply this choice …” has no effect // also restarted PL6 )

1 Like

Thanks everyone for having a look and especially for having the same exact problem as I did. It is very strange indeed, but also very clear that PL6 is 100% at fault here. I guess the algorithm is simply making the wrong decision based on the information programmed into it as well as the information it gets from the files.

But, the bigger mistake was made by the people or person at DXO who had the “genius” idea to completely rely on the algorithm in a critical decision such as lens make and model when dealing with what is one of the biggest selling points of the software: How it handles optical corrections. That amazingly short-sighted decision has dramatically reduced the value of what I have been loyally paying for over the last several years.

And…I haven’t gotten any response from DXO customer service so far. Maybe their customer service algorithm is having problems as well.

I’m afraid we’re looking at the wrong place. It’s only an assumption, but reading various posts of you @bconner (which are very clear, helpful and informative) I doubt it to be a software problem. If FocusTune and Reikal already misidentified the lens before it might as well be that

  1. a lens contact is broken, not properly soldered or in the wrong place.
  2. a mechanical problem occurred with the spring loaded contacts inside the camera’s mount
  3. the internal ROM of the lens was not properly initialized (but then none of your images would be recognized at all).

I tend to possibility 1. We take it for granted that electronics in lenses just work, but the more stuff is in the more possibilities for failures. In fact, I had also a lens exchanged because the first copy of the Irix 11/4 was neither identified nor could I set the electronically managed aperture. It worked fine in the beginning, but one of the gold plated contacts bent after a while.

Also, it’s sometimes recognized and sometimes not let me assume it to be some sort of loose contact. What you could try (if you dare and feel comfortable): wipe the lens contacts clean with a microfibre cloth and a drop of 65% alcohol on it, do it carefully. I was looking at the lens’ contacts of a Canon lens. 5 are raised relative to two slightly recessed. The recessed ones have a smaller gap of plastic between. Meaning, the contact pins of the camera body need to be precisely in the right spot.

I’m now 100% sure that it’s not PL’s fault. The EXIF of both …hard copy files show generally empty lens info.

Except the Lens Info with 24 70 0 0 is given, but nothing else and the serial number is also a long mistake of 0s. When there’s no written info in the RAW file, no converter could read anything.

Coincidentally two things happened: the assumed mechanical or electronically problem became worse and PL 6.5 was published / installed. Now it seems PL 6.5 is the problem, but I think, not this time.

Thanks for your reply.
I also could not find any difference in the information contained in the EXIF pertaining to lens model or manufacturer, but that would not explain why PL6 could correctly identify the lens used in one image, but not the previous image.

Being able to manually choose the correct profile, as in PL5 and before (and in Lightroom etc.) would make this a non issue. But as it stands, I am forced to use either no profile or an incorrect one. That is very short-sighted on the part of DXO.

When the camera is reporting that it is either a Sigma or Tamron as shown below. Then the camera has some idea of the lens make, but just isn’t sure. Maybe due to the same lens identifier being used by both Tamron and Sigma. In this case DXO is deciding to choose the Sigma and not the Tamron…which is the wrong decision. If information isn’t completely clear, the software should ask the user. In my opinion, that is common sense.

Re-checked the two card copy files with ExifTool and different apps and found that apps have a hard time allocating the lens…which is to be expected since both Sigma and Tamron seem to use the same numerical LensID as the Canon Canon EF 85mm f/1.2L USM as shown by ExifTool

[MakerNotes]    Lens Type : Canon EF 85mm f/1.2L USM or Sigma or Tamron Lens

I suppose that apps also see that you used an EOS R body, which (sort of) eliminates the Canon lens, which was engineered to be used on SLRs. Why all these apps pick either the Sigma or Tamron lens or both is difficult to understand though.

As ExifTool and BBEdit see no differences in lens info, I suppose that your gear is okay. (13.6 KB)

I tried several ways to work around the issue


  • Hardcore Hack: Edit metadata with ExifTool to add the “Lens Model”
  • Temporary Fix: Edit the DPL’s database as outlined above

Caveat: Adobe DNG Converter solves the problem in this case. It doesn’t solve all lens recognition issues though. Results depend on the info it finds in a file. Not all files are created equal though.

On the possibility of choosing the profile if the situation is unclear, I absolutely agree. This is a long term flaw of PL and I don’t understand the reason they keep it that way for so long.

That the camera sees two possible lenses is bewildering me. I can’t say “I never had this”, simply because I don’t control every image for proper EXIF data. It just never popped up when something went “the other way”. But initiated by your post I scrolled through some recent images made with a rented Nikkor 19/4 PC E (the lens has contacts for electronically aperture operation). Used with a Z 7 and FTZ adapters, all genuine Nikon stuff: No lens EXIF available except “19 4 0 0”. No maker, no serial number.

Standards which are effectively no standard are rather pointless.

Edit: Interestingly Capture One also believes in a Sigma lens:
Bildschirmfoto 2023-04-16 um 10.48.58
I really wonder where that comes from?

Maybe someone at DXO decided that when the lens is not 100% known, then it MUST be a Sigma 24-70 F2.8, either the IS or non IS model. :rofl:

I downloaded the test version of Lightroom CC and it also guessed at a Sigma, but it gave me the choice to choose. And as soon as I changed the lens manufacturer from Sigma to Tamron, it automatically selected the correct Tamron lens model for me. This makes me believe that it might indeed be a lens identifier issue that DXO is incorrectly solving on its own.

Back to the fact that we can’t choose our own lens profile when PL6 isn’t sure. This is a big failure/oversight on the part of DXO.

But…Adobe DNG files converted from EOS R files also don’t have the lens correction/Optical module capability…there isn’t any lens sharpeness etc with dng files, regardless of which lens is used. Even with my Canon 70-200 (EF) F2.8 II lens, or another Sigma lens…or my Tamron 45mm lens. But, with the CR3 files, optical corrections including lens sharpness are available with all lens combinations. Well that is up until v6.5 in my case.