How can a new host application join Nik collection certification?

What I know so far is that photoshop and affinity can call Nik Collection as a plug-in. If there is a new host application now, it call the Nik Collection in the form of a plug-in, how can I get the certification of the Nik Collection, and what are the standards for obtaining the certification?

That sounds like a question only DxO can answer. In which case you need to ask them via this page:
because despite the URL of this forum including the words ‘feedback.dxo’ this site is a user forum

sounds sad. is there anyone in DxO?

This being a user forum, the chances of DxO answering your question are very low.

What “new application” are you talking about? Does it support plugins? Who is the author?

As far as I know, the plugins are available as *8bf files. So any application that can use Photoshop compatible plugins should also work.

I tried the Silver Efex plugin with freeware a long time ago and it worked.

Maybe just try it

best regards

1 Like

Does it need a certification? The Nik plugins are used with a batch like command: Export to disk and Open with.


yeah! I use *8bf files call plugin ,the UI can display.but the UI not like photoshop or affinity.Maybe now need certification.

You might have a look here … and for further links below that post.

This “mixed” installation works on Windows 10
(don’t know about Win 11 – and as I think I’ve read not with MacOS)

in Affinity Photo 2.x I can work with these PlugIns
Screen Shot 08-10-23 at 10.56 AM
( except Perspective Efex !! )

as well
Screen Shot 08-10-23 at 10.57 AM
( didn’t bother with FP5 )

1 Like

That’s a Export and Open with batch like command. I think he is asking for other software.


At the moment I’m still puzzling over what it’s really about…a little more information would certainly be helpful.
I am now devoting myself to other things again :grin:

I use Nik Collection 4 , the problem seems disappear. thanks.

What application are you calling Nik Collection from? I am taking a guess that you are using an application and that it cannot see the Nik plug-ins; am I correct? The reason I ask is that I use ACDSee Ultimate to manage and sometimes edit my images. The last version of Nik Collection where I can use all of the plug-ins is 5.0.5. When I install any versions after that I can no longer see all of the plug-ins. DXO made some change, likely to accommodate Photoshop. I asked DXO about this and their response is simply that they don’t support Nik Collection with ACDSee. So I no longer upgrade Nik Collection.

Is this the problem you are having, or am I just confusing the issue?

Correctly. but not all. In fact. It’s the Nik plug-ins cant display a button which is used to write image back to host application. I can use plug-ins is 3.3

1 Like