Export DNG 'optical corrections & denoise only' now doesn't crop anymore

Basiaclly what the title says.
An image exported as DNG-optical-only now looks like this:

which is exactly as if the crop tool is disabled in DXO Photolab.
But the crop tool is enabled and set to auto, and DxO shows no black borders.

I now have to manually crop out black parts in the tool I use to process the DNG further. This wasn’t the case before 6.3.

So DNG exports gets destroyed bit by bit now…

Have a look at this thread, it shows how you can change the defaults for ‘constrain to image’ to get the old behaviour back.

1 Like

Yes, can confirm this strange behaviour.

Inspite of having used the preset “1-DxO Standard”,
which contains Crop / Correction Auto based on keystoning / ho … →

the exported DNG (Denoise & opt. Corrections only) does NOT crop.

@DxO_Support-Team – please take note

Hello @Wolfgang
I’m sorry, maybe I did not get your point?
If you chose the export option “DNG optical corrections & denoise ONLY” why would you expect any other correction applied than optical corrections & denoise?

If you want more corrections to be applied, choose “DNG - All corrections expect Color Rendering”


Ok, that excludes cropping – didn’t realize at the moment. :man_shrugging:
Thanks for clearing up.


I just double-checked, the crop as part of the Distoriosn correction is also applied, for the export “DNG optical corrections & denoise only" according to the settings chosen in the distorion palette. You might want to select the option “constrain to image” like shown in the screenshot above. This will be the equivalent ´to what has been used in the past. Those options have been added with PhotoLab 6.3.1

However, any other crop will not be applied with this export option.

Prior to PL6 it was common that the crop function was activated.
It’s still in the standard preset. All the other presets don’t have the crop activated.



So ‘crop’ was always ignored with Denoise & Optical only,

but this checkbox was ticked in the distortion module and now it isn’t anymore.

I can understand and live with that, I thought ‘denoise & optical only’ was broken and forgot to apply something it did before.

Thanks again!