DxPL(Win) 6.9.0 Loses all image entries in the database & Hangs when trying to access Projects

While testing DxPL(W)6.9.0 I have encountered two situations where the database has lost all the image data plus the product hangs when attempting to access ‘Projects’ @DxO_Support-Team

DxPL(W) Hangs:-

I first encountered “Hangs” when producing this post PhotoLab's Pleasant Simplicity - #8 by BHAYT. In that case I reported the following

While testing for DxPL(Win)6.9.0 - Changed file name in another package what I did to fix the result in DxPL I encountered further hangs which generally cleared after DxPL(W) was terminated (with prejudice) and restarted

Loss of data in the database:-

However, the hangs are nothing compared with what also happened while undertaking more tests when I lost all image data from the database on two separate occasions. The Test structure looks like this with Renamed directories identified with (R?), i.e. (R), (R1), R(2) etc.


The following is the log I wrote during the tests using a database with a number of directories and a number of associated projects.

The aim of the tests was to verify that the method of recovering ‘Projects’ when the name of a directory is changed outside DxPL worked but I got more than I bargained for

  1. I closed DxPL with an earlier test directory (Test 15) selected, because I was going to change the directory name for Test 16 so leaving DxPL pointing at that directory was not much use. Please note that I believe that I closed the database before making the name change but …
  2. I renamed the Test 16 directory
  3. I copied the baseline test directories to my NVME ready to undertake recovery tests.
  4. I (re-)opened DxPL
  5. There were no images in any of the projects, i.e. the ‘Project’ names still existed as did the Keywords but essentially the entries relating to the renamed directory appear to have been removed from the database!? While we have long asked for the ability to clean up the database (on request) that capability is not supposed to exist!
  6. The ‘Folders’ structure contains only the structure I closed DxPL with!
  7. The ‘Projects’ structure is intact

but no items are present for any project because there are virtually no ‘Items’ (Images) present in the database at all!

  1. The ‘Items’ structure is largely empty except for the two images that it contains

    . Although I had changed the name of the directory, DxPL is supposed to leave the database entries intact and my tests were to show how any ‘Projects’ related to those “missing” entries can be “fixed”. That is difficult to do when no entries exist in the database!

  2. The keywords table is intact


  1. I backed up the damaged database and instructed DxPL to restore a backup I had made before commencing tests but delayed the restart and closed DxPL.

  2. I restored the image directories to a form that corresponded to their state when the database backup was taken and restarted DxPL.

  3. It restarted showing project “P - 01” and hung as it had in some tests a few days ago @DxO_Support-Team.

  4. I terminated DxPL and restarted and it restarted successfully and all projects are intact, no missing entries etc.

  5. Selected Test 15 and changed the name of the test directory using another program with DxPL running!

  6. The ‘Folder’ structure is intact and ‘Projects’ show all image entries as missing with the thumbnail and the “!”(just as they should as they should be)

  7. I restored the same database backup but with the directory still renamed and all worked as in 15, no repetition of the previous data loss.

  8. I then changed the name of the directory back to its original name via DxPL(W) and all the ‘Projects’ show as empty when viewed and some (but not all) have their counts changed as well!


  1. The ‘Projects’ table shows the project names but the ‘ProjectItems’ table is empty, the ‘Items’ (Images) Table shows as empty,

the ‘Folders’ structure shows no sign of the Test 16 directories

  1. I then repeated the exercise again and did a test where it all worked perfectly
  2. Changed name in DxPL and ‘Projects’ automatically re-aligned!

Testing Revisited:-

After a day with no testing yesterday I made an attempt at testing again this morning

  1. Restored my test database and it hangs DxPL when attempting to view a project so terminated and restarted.
  2. I conducted some tests but then realised I was changing the directory names of a copy of the Test directories and watching the ‘Projects’ of the original (restored) files - oops.
  3. Switched to the main group and changed the name of a directory in the correct group using DxPL and this was the result
  4. The ‘Project’ is intact but DxPL cannot find the correct entries for the normal display
  5. A restart did not fix the problem, i.e. it is a “corruption” to the database

Enough is enough @DxO_Support-Team please contact me and I will see if I can provide you with whatever you need to diagnose and fix these problems.



@DxO_Support-Team having repeated the empty directory problem repeatedly

I tried to create a smaller test set to enable easier analysis! The database contains 5 images and 5 projects and four attempts to backup that database have failed

  1. First attempt was made with DB Browser running and submitted
  2. Second attempt DB Browser was terminated before attempting dump but error occurred E8DBF544-EC0C-4C84-AFB7-016D76D35F24
  3. Third attempt failed but I did not report
  4. Fourth attempt error E8DBF544-EC0C-4C84-AFB7-016D76D35F24

So I cannot successfully backup this tiny database with DxPL(W) 6.9.0!

Backup after repeated crashes while trying to Dump.zip (105.1 KB)

Neither can I successfully close it so I have managed to create a tiny “toxic” database!?