DxO PureRAW 3 free trial download & installed but not available

Thank you for your help. I just downloaded and installed the free, 30-day trial of DxO PureRAW 3. It was added to my applications folder but it will not run. When I try to access it to process a photo (Canon R3 RAW image) in Lightroom Classic (12.2.1 Release, Camera Raw 15.2), DxO does not appear anywhere. My usual workflow is to open a photo to be edited in Lightroom Classic, then in the “Photo” drop-down menu I select “Edit In.” All of my Topaz plug-ins appear there, but DxO PureRAW 3 does not. I tried clicking on the “DxO PR” icon that was installed with the download but all that does is it displays the screen inviting me to download the free trial or buy the software. This is the stage in my usual workflow where my photo to be edited opens in Topaz DeNoise AI, which is the denoise software that I currently use. How do I get DxO PureRAW to open, apply its denoise AI improvements to my photo, and then send it back into Lightroom Classic where I may continue editing? My final edited photos are JPEGs — not DNGs or anything else, to save storage space. JPEGs are good enough for my needs. FYI I have one HUGE Lightroom Catalog, where all of my tens of thousands (perhaps hundreds of thousands) of photos — and edits that I made to any of them — are catalogued. I intentionally only have one Lightroom catalog for editing because I need to be able to see and search for my photos in one place (I am a member of the press and often need to find some of my old photos).

Hi Jan,

Have you tried deinstalling of removing DxO PR and reinstall it again. My first impression is that something went wrong during the installation of PR. I don’t use PR but Topaz Photo AI and DxO PL. Perhaps a second check is to look at the necessary login items, are they loaded/enabled.