DxO PL3 Virtual Copies - 3.1.3 Build 48

In the latest build of PL3 (48), virtual copies are still causing fits. I have noticed a few crashes related to management of virtual copies, most especially deleting them.

Typical work flow is –
(1) make one or more copies
(2) work with one or more of the copies
(3) decide among them which one I like; transfer the settings to the master
(4) delete the copy(-ies)
(5) crash.

In the filmstrip, I also occasionally see a large question mark instead of an image, and this too happens after a delete.

If there is any way I can help debug this – such as by providing one of the massive crash dumps that Mac OS provides – I’d be happy to.

MacOS Mojave by the way.

I don’t get crashing with Catalina but, yes the UI is not getting updated correctly on addition and deletion.

FWIW, I don’t even get a virtual copy created with this build. I did before! The original is marked with an “M” but no copy created.
macOS 10.15.3

Have you tried moving to another directory and back again in the library view?

Well was a start. However, in the previous version just before this recent update, I was able to create a virtual copy in a “Project” but now after creating the virtual copy, it it is go to library view, go to a different directory, go back to the original directory, then “manually” add it to a project.

Starting to get more and more like Adobe updates.

I can still create a virtual copy in a project with 3.1.3 build 48. What you describe (seeing only the “M” but not the copy itself) sounds very much like the issue described here: PhotoLab Bug! Virtual copies do not update film strip by @Joanna.

How do you start PhotoLab? Directly from the Dock or by using “Open with…” on a file or from another application?

My usual session process is as follows:
-Load photos from camera into Adobe Bridge CC and then add exif tags and cull as needed.
-Open PhotoLab, from dock, in file browser view and select the downloaded RAW directory
-Select all and immediately create sidecars
-Move all selected files into project “Today”
-Then choose project “Today” in browser view
-Switch to customize view
-Return to Bridge then select and open image into PhotoLab (perhaps this is were the issue comes in?)
-Apply presets and tweaks (sometimes multiple photos and definitely multiple with pano shots)
-Export to Bridge.
-Then switch to Bridge, replace the appended “OpenWith” (which PhotoLab in its infinite wisdom will not let you customize) and more often than not open the exported image in another app to add final touches and then move the processed image to a “processed” directory.

It is during this workflow when I will come across a particular image where I want to try differing adjustments or presets and 'try to create" the virtual copies.

Only on rare occasion do I ever open PhotoLab from Bridge or Finder and when I do it is a “one off” redo or special export.

BTW, PhotoLab has been very stable for me on Catalina.

When you open an image from Bridge into PhotoLab I’d expect it to be opened in the original folder and not in your Today project. Then the virtual copy would be visible in the folder only, not in the project.
If you leave out this step and directly select an image in the Today project do you have the same issue?

Still it would be odd behavior from PhotoLab to show the filmstrip of the project while the image is actually opened from the folder. I could imagine it is related to the problem that Joanna found.

All this back and forth looks pretty complicated to me.

FWIW, the only time the image is opened in the original folder from Bridge is if PhotoLab is not open. The rest of the time, what ever state PhotoLab is in, that is what you get when you open a photo from Bridge (or Finder for that matter). However, in “project” view, you need to select the photo.

I needed to put photos into a “project” because in past versions, I would end up getting “fatal” database errors and would have to quit PhotoLab and restart. Whether that is still true, I haven’t tried in a long time. Also, in the “projects” view, it can hide those items I don’t want to clutter PhotoLab that you get with “file” view.

Also, FWIW, as long as Adobe still lets me use Bridge for free without any subscriptions, I use it as my primary “media” work hub.

Yes, I just tried and found that as well. So why do you go back to Bridge again after having created the project?

That’s curios because projects rely even more on the database. If you work in the folder only the database is irrelevant and you can delete it provided you let PL create the .dop files automatically.

“So why do you go back to Bridge again after having created the project?”

I export PhotoLab a processed image to Bridge, and as stated launch additional app for further processing (ex. pano stitch, HDR merge, or just “prettying”), returning to Bridge then move the finished product to wherever. As stated, Bridge is my “app agnostic” media management hub.

“If you work in the folder only the database is irrelevant and you can delete it provided you let PL create the .dop files automatically.”

Apparently not in the past as this gave the database error which created bizarre behavior and required quiting PhotoLab and is why I used project view in the first place. And yes, .dop’s are automatically generated. Perhaps this isn’t true anymore? I will try next session and see what happens.