DxO PhotoLab 2.3.1

Hello Everyone :slight_smile:

We’ve just released the 2.3.1 version of PhotoLab, including bug fixes and the support of 4 new camera bodies as well as 15 new lenses.

New Cameras & Lenses support

Camera Bodies

  • EOS 250D / Rebel SL3 / Kiss X10


  • GFX 50S
  • Fuji GFX 50R
  • Fuji X-T100


  • EF-S 18-55mm F4-5.6 IS STM
  • RF 85mm F1.2 L USM


  • GF 32-64mm F4 R LM WR
  • GF 23mm F4 R LM WR
  • GF 63mmF2.8 R WR


  • Z 14-30mm F4 S
  • Z 24-70mm F2.8 S


  • M.Zuiko Digital ED 12-200mm F3.5-6.3


  • 14-24mm F2.8 DG HSM Art - Canon mount
  • 28mm F1.4 DG HSM Art - Canon mount
  • 40mm F1.4 DG HSM Art - Nikon mount
  • 105mm F1.4 DG HSM Art - Canon mount


  • FE 135mm F1.8 G Master


  • SP 15-30mm F/2.8 DI VC USD G2 (A041) - Canon mount
  • SP 15-30mm F/2.8 DI VC USD G2 (A041) - Nikon mount

Bug Fixes


  • Changes applied with local setting tools are no longer lost when you switch to full-screen mode.
  • PhotoLab now updates any changes made by third-party applications to xmp files.
  • Minor Bugs


  • The graduated filter works correctly when you use the delete button
  • Minor Bugs

Installed on W10 as usual. Application fails to start. Restarted PC makes no difference. Now stuck with non running PL.

Something wrong, help please.

I reported this first thing this morning. Work in IT industry. Had a feeling it wasn’t me.

Now my original post is gone or removed. Svetlana, was it moved?

I also tried a repair (which cannot be performed) .msi missing. And finally uninstall, reinstall. No dice.

You’ll need to reinstall the last version. (Which I did and that works). BTW, if anyone needs the previous version, I have every build released since 1.1 archived.

Glad to see it has visibility now. I’m sure the issue will be resolved quickly.

Glad this was brought up quickly. Just had the option of the update so I have declined for now (nothing I really need in it anyway!).

I will hang fire for now.

For what it’s worth, I installed the update on my Windows 10 machine, running version 2.3, this morning and it updated with no issues. My machine also has all available Windows 10 updates installed.


Like Mark, I installed the update on Windows 10 this morning and haven’t experienced any problems.


Did you open the program and when prompted to update run the download, or did you close PL, visit the downloads section, download the latest build and install that way?

It matters as the installers could be compiled differently? I know for certain what I downloaded (stand alone) package didn’t work. Not even a fresh install. No errors, no issues, but the software would not start or run once it completed. I’m going to download it again and upgrade. Will report my results shortly.

I did run the update when prompted - everything fine.

Hi Rick - - A few comments on the issue you reported.

I must have been one of the first to have installed the new 2.3.1 version (being in Australia gives me a time advantage). I know I got it early 'cos I did some work with PL 2.3 - then closed the app and re-opened it a few hours later - and was then presented with the update notice).

My environment is exactly the same as yours - as you advised here … but I had no problem with the installation. I downloaded the upgrade when prompted by PL 2.3. One difference, perhaps, is that I did a reboot before I installed the new version.

Regards, John M

Thanks John.

I no longer have access to the thread I posted this morning. Not sure why. When I click the link I get


This is my error when I try to run the software:
Faulting application name: DxO.PhotoLab.exe, version: 2.3.18112.4028, time stamp: 0x5d473b1d
Faulting module name: KERNELBASE.dll, version: 10.0.18362.267, time stamp: 0xf09944f9
Exception code: 0xe0434352
Fault offset: 0x000000000003a839
Faulting process id: 0x1ff8
Faulting application start time: 0x01d54da55508ffd1
Faulting application path: C:\Program Files\DxO\DxO PhotoLab 2\DxO.PhotoLab.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: 19feaed9-9c1a-4f65-baed-77baf048ac04
Faulting package full name:
Faulting package-relative application ID:

Last windows update I applied:
July 26, 2019—KB4505903 (OS Build 18362.267)

Am going to try the upgrade method in the program now. Have to downgrade first. Back shortly.

Nope. Not working for me. Have now tried both methods.
In program update
Fresh install
Uninstall/Reinstall with restarts, etc.

Ran SFC /scannow - clean
May try the MS Installer tool next

Mmmm - Yep, curious !

The size of the 2.3.1 installer that I downloaded (and successfully installed) is 350,424,416 bytes … Is yours the same ?

Regards, John M

PS. Just noticed: My Win10 environment IS a bit different from yours. DxO_Win

Think I found the issue (maybe)

You are 18362.239

I am 18362.267

Kernalbase.dll modified 8/6
Look at the file version.

Compliments of MS

Going to roll back and see if an earlier kernel base does the trick.

2 fresh copies of the installer downloaded… both are: 350,424,416 same as you.

Nope again. At .239 now and same error. Oh well, tomorrow is another day.


Same problem here, PL doesn’t open after update. I used System Restore to get it work again.

Updated win 10, same problem, tried 3 times, no succes. Luckily I had 2.3.0 and I reinstalled it and it works!


  • It was not me but yes, it’s moved.

We will work on the problem as soon as possible.

Svetlana G.

  • Yes, this problem affects only some Win10 users, we will investigate it asap to find the course.

Svetlana G.

Rick, I fixed the issue. Now you should see your post.

Svetlana G.


To be clear, i do not install v2.3.1 yet?
Wait for the fix i suppose?

1 Like

Ya. Probably best for now. I just rolled back to 2.3.0_23891.

Will wait for the next build.