2.3.1_24028 - Is It Working For You?

Good Morning,
Might be the only one, but I could not get 2.3.1_24028 to run on my W10 PC.

I downloaded the new installer from my account and installed it over my existing install of 2.3.0_23891. Same as I always do.

Everything completes, but the product does not start when clicked.

I uninstalled it, restarted and reinstalled with the same result.

I then re-installed 2.3.0 and all is well.

For Reference:
W10 Pro x64
Build 1903_18362.267
Fully patched

Not having any issues with my machine except with the new PL version. Post should probably be moved to DxO PhotoLab section instead of News and Announcements, sorry about that.


Could you, please, try to re-download the installer? Sometimes it’s not properly downloaded and get corruptered.

Svetlana G.

Hi Sveltlana,
I will do that. I downloaded the installer stand alone from the support portal. I do not upgrade running files directly from the web. I always download first and run from local storage.

Although the installer does not report corrupt or exhibit any problems / issues during install, I will re-download and run the upgrade again.

Have a gigabit connection, only takes seconds for me to download.


Cool, I’ll wait for your results.

Svetlana G.

i move this topic to “Windows feedback” session

Have access again. Thanks Guys!

1 Like

You are welcome! Just a question, what type of processor have you got?

Svetlana G.

i7 4790K 4th Gen (Devil’s Canyon)

Z97X-UD5H (F8) \RM850w, 4790K, 16GB Vengeance, RTX 2080 FTW3 Ultra, 850 Pro’s RAID0, 1TB WD, W10 1903

1 Like

Okay, thank you.

Please, try the procedure I asked you via a personal message.

Thank you.

Svetlana G.


I wouldn’t be so critical :unamused: - it’s rather the exception for us to fail the release (do you remember when it was before?) Moreover we are releasing the hotfix asap.

The good lesson is to store the previous installer somewhere :wink:

Anyway, sorry for the inconvenience we will deliver the fix today.

Svetlana G.

FWIW, the v2.3.1 update installed OK on my WIn 10 Pro x64 desktop PC with no apparent issues.

Regards, Peter

1 Like

V2.3.1 update working fine also, Win10 vers1903

We just released an official hotfix for DPL2.3.1.
Please down load this installer, the issue should be fixed
!! Link edited by moderator !!

Svetlana G.


The revised installer worked fine on my Win 10 1903 desktop PC.

Regards, Peter

A good lesson learned from this would be to number EACH installer with it’s version number rather than the generic PhotoLab2_setup.exe which you do for every single version.

i.e properly name each download according to release number. - PL2_Setup_ver_2.3.1_24028 for example.


Fixed version 2.3.1 seems to work…

1 Like

I agree and would like this also. I currently use the check for update, and note the version number, then cancel the upgrade and visit the support portal, create a folder on my machine and name with the installers build number, then download.

There are other methods (like grabbing it from the temp folder) but as long as I get it archived is all that matters to me.

Would also like to point out (and agree) with what Svetlana said. This is a very uncommon occurrence for DxO. It has never happened to me previously. (User since 1.1) Minor speed bump, Nothing to be upset about. They addressed the issue quickly.

I’ll be upgrading mine today.


I had problem with recent install which I did not experience before. It did not install on any of my systems which had the TMP/TEMP on ram disk!

The installer fails in this case. When I move the TMP entries back to the C: drive it installs.

That’s bad because i need two reboots to install it!

Not sure I follow. You have a problem with installation because you choose to run your system in a non-standard configuration and you’re surprised when you have issues installing software? The “problem” and solution appears to be obvious.


What is a non-standard installation? I only have the TMP folders on another drive, I had this for years and had no problem, even with DxO in the past, but now the DxO installer is the ONLY one which stops and says it cannot find setup!

So I give feedback to DxO that there is a new problem introduced.
And I also knew how to overcome it for me but un future, if I would be DxO , I would look into it.