DXO PhotoLab 2.3.1 b43 export doesn't work

DXO PhotoLab 2.3.1 build 43 export doesn’t work on my macOS Catalina GM (10.15 - 19A582a).

Hello Miroslav,

I´m a little surprised, OSX Catalina not yet available, or are you one of the “chosen” Beta-Tester

I trust you notified the Dxo folks of the incompatibility. I guess this is why I wait to update the OS on my MBP.


It’s not just Catalina… I have 2.3.1 build43 and updated to 10.14.6 Supplementary Update 2 yesterday and now I can no longer export.

Doesn’t matter if it’s export to disk, application or Lightroom. Just sits there without spawning XPCCor1…2…3 etc.

I’m getting errors in my log.

DXOPhotoLab2 XPCCor : Connection did interrupt for com.dxo.XPCCor1
DXOPhotoLab2 *** dopcorDidEnd DOPCOR FAILURE

Export worked fine last night - Catalina after the minor bugs update. Exported two photos to Original Folder, one in 0.2 secs and the other in 0.6 secs - although the cropped image took longer…

Did you try on to the last update of PL 2 ?

I just tried exporting a CR2 file to Jpg on a Macbook Pro with Catalina with the update. It exported with no issue. It just did it.:blush:

After completly removing app with AppDelete and reinstall everything works as expected. Just deleting app from Application folder wasn’t enought.

Mojave latest, PL 2.3.2 b44 no problem to export anywhere in any format, NK included.

Hi there,

we have run extended tests on both macOS Mojave 10.14.6 Supplemental Update 2 (18G103) and macOS Catalina (19A602) and could not find any processing issue yet.

Do any of you still have trouble with PhotoLab on either one of those OSes? If so, can you send me any crash report (Console.app -> User Reports) and/or relevant system log info?

Btw thanks GraXXoR for reporting your info, we looked into it but unfortunately ‘Connection did interrupt for com.dxo.XPCCor1’ is just confirming the failure but does not give the root cause, we’ll need additional info. Do you still encounter the issue?

Hi Ingmar,

as I wrote previously after completly removing App (using third party software to remove all data) and reinstalling app everything worked perfectly again.

Have no idea what went wrong.