"Processing Failed for an Unknown Reason" - error message

You are welcome Mike, I hope now that DxO will help you with this.

No wonder you got a fault, when contracting with the ‘devil’ :slight_smile:

Ok, more seriously

  • Did you crop off your watermark ?
    → I can’t see that (always have to undo), but then your history shows that you cropped first.
  • Is it a memory (RAM) problem ?
    → Is it the first time you exported that number of pics at once?
    The problem could have been there already with PL 4.
  • And then, there were pics you could export w/o problem.

The screenshot from your pic w/ dop-file showed me, that there was a problem with your processing.
– but it’s not ‘repeatable’ on my side.

  • I had the watermark undone, made a VC and could export from it – without problem.
  • To countercheck I deleted everything in PL5, closed the program, then only copied the raw-file to my test folder and exported in PL5 as before – without problem.

I’ll go with this answer!!! :slight_smile:

I never added a watermark to some images, as I was just trying to figure out what is/was broken.

Yes, it was the first time I exported that number of images at once, but that is not the problem, as it happened today on exporting just one image.

It may not be repeatable on your side, because you’re not using Apple Monterey?

Many hours later, I downloaded some new photos taken of an iguana again. Out of all the images, one was good enough for me to keep. I edited it, and tried to export it, using DeepPrime. I get the error again. I also got it on another one of my Halloween images - again, turning off DeepPrime and switching to Prime fixed the issue. I should add that the DeepPrime processing of my exported images takes a long time. Maybe some “buffer” is running out of space?

I turned off DeepPrime, and selected the old Prime. Everything worked fine. Here’s the exported image:

Most of the time DeepPrime works. Maybe three out of ten tries it “crashes”. Every time it “crashes”, if I switch to Prime, it exports fine. The only real change I made to my computer was to upgrade to Monterey.

I have two utilities that monitor “diagnostic” information. Next time I will leave those running, and process an image that always crashes in DeepPrime, and see if there are any obvious signs of something being wrong.

I read that DxO turned off some features in the macOS release because of compatibility issues with Monterey. Maybe this is something similar.

Well, I can’t help you with Monterey – or can you go back to the former OS version?
Didn’t run it properly?

nice Iguana shot!

Yes, the previous OS, Big Sur, ran fine, but Apple is constantly upgrading their OS to provide new features and correct bugs. macOS Monterey is going to allow my Mac compute to work better with my iPad, and supposedly my keyboard and mouse will also control the iPad, along with allowing the compute to use the iPad as “another screen”.

What I don’t know how to do is run a “log file” for diagnostics, which I could send to the tech people at DxO who would identify the error and fix it (if the error is Monterey causing PL5 to fail).

As for the iguana, I saw it, and walked past it, and stopped. It looked at me for a while, then it moved forwards several feet. So, I looked away, moving past it, but getting closer. We both played this game until I thought I was close enough, when I raised my camera, and turned to aim the camera at the iguana, with my face hidden by the camera. The iguana stared at me while I took photos of it, getting lower and a little closer. Eventually I stood up, lowered my camera, and stared at it, as it stared back at me. We did this for a while, until it got bored with me I guess, turned, and walked away. So I moved away too, and went food shopping. Oh, I was NOT as close as the photo makes it look, probably four feet away. For me, and I guess for the iguana, that was close enough.

Back to the discussion, maybe Monday some tech person at DxO will ask me to run some tests to try to figure this out, or maybe they already know about it?

I ran “Activity Monitor” while Exporting.

I have no idea what “XPCCor1” is or does, but when I’m not using PL5, its CPU is 0 %

While Exporting I got this:

I thought I saw it up to over 600. And when Exporting finished:

I have no idea if this is a useful clue. However, this link mentioned it for an earlier version of macOS:


1 Like

Hey sir I’m still operating on PL4 and I have had pretty much nonstop issues and problems with respect to processing and exporting files ever since I updated the software on my MacBook Air… I’ve encountered similar problems throughout my time that I found this photo editing program, it gets quite annoying and I’m terrible at troubleshooting tech issues… In addition to getting the same exact notification that you did with respect to the file not exporting, now I’m getting an even larger problem with Photo out for only allowing me to now use the prime option as when I try to select the deep time there is a grade out area where the preview window is for the noise reduction of the deep prime and it says it will be offered soon by Apple’s new software… So the only thing I can do is run it through the prime which isn’t nearly as good for some of my high ISO images and try to do it like that which sucks because I paid all this money specifically for the one thing that’s not working

That’s the fun part for early birds.


Could you please try to collect logs either by copy-paste it from Console or using diagnostics script you can find here https://download-center.dxo.com/PhotoLab/diagnostics/DxODiagnostic.command.zip ?
If you need any help about how to use this script just ping me.

Best regards, Alex


There is a known issue with macOS Monterey and DeepPRIME. We expected this to happen mostly only with the loupe, which is why loupe is disabled in this case. This was one important reason for DxO PhotoLab 5.0.1 release. In the meantime, export with DeepPRIME remains enabled.

We’ll see with the logs that @akarlovsky asked if the issue that you and @mikemyers noticed are the same issue as what we already know for the loupe.

Regarding the issue with loupe, here is the information we have so far:

  • when the issues happens, the application crashes. Exports are done in a separate XPCCor process as @mikemyers already saw. XPCCor crashes are one of the possible reasons for the failure with “unknown reason”
  • it happens randomly but is much much more likely to happen with the loupe than an export, which is why DeepPRIME export are still allowed
  • it is specific to macOS 12 when processing DeepPRIME on CPU, it does not happen with Apple Neural Engine or an AMD GPU, or with macOS 11
  • Apple was made aware of this issue a few weeks before macOS Monterey was officially released, and at the moment the issue remains

Best regards,

1 Like

Certainly!! Will do, later today. I think this is exactly the right tool, so DxO will understand where the real problem is. Thank you!!!

I should add that for me, while this is an annoying issue, I can, and still, use PL5 exactly the same as before. The program has never yet “crashed”. When the EXPORT fails, I just switch to PRIME instead of DeepPRIME and that always works.

Also, an image that breaks DeepPRIME does so no matter how many times I try. The next image in my photo sequence usually works fine. I can post two very similar images here, taken within minutes of each other, and you can use my .dop file and probably get consistent results as to breaking the process, or not.

When I get home this morning, I will take an image that “breaks” DeepPRIME and un-do all the changes I have made, so I’m back to the original image, and ONLY select DeepPRIME and test if it works. If it does work, then something else I have done is what causes DeepPRIME to break. This will be an interesting test.

Lucas, if you look over my Halloween photos, the ones that I used DeepPRIME for are the ones that processed correctly. The very similar images that you’ll find where I only used PRIME were the images with the problem.

When I tracked it down to DeepPRIME, I thought I was finished with what I was able to do or test, but thinking about it now, it might be because of DeepPRIME, and ALSO one of my other corrections. I’ll see if I can figure this out.

In the meantime though, I’m now able to do just about everything I want, and if DeepPRIME doesn’t work, I just use PRIME. For me, it’s not that big a deal - sort of like getting a piece of cake that came without the icing on top. The cake still tastes great!! …and I am still happy. I’ve been doing computes since I started out with IBM punch cards, and I’'m always surprisingly happy when things DO work as they should. I’ve learned to always expect problems, and then try to figure them out. I used to work in the Quality Control Dept. at a software company, because I was so good at getting software to break. :slight_smile:

Small problem:
Screen Shot 2021-11-03 at 12.26.35

Here is the file that I’ve been working on - (VC1 crashes)
_MJM9431 | 2021-10-31.nef (29.2 MB)

_MJM9431 | 2021-10-31.nef.dop (24.9 KB)

This is a screen capture that shows the “clipping”:

In the (M)aster file, I removed all the history except for “Applied Default Preset”, and then turned DeepPRIME ON. It worked, twice in a row, taking around a minute and a half. I’m no longer so sure DeepPRIME is causing the problem. You can examine my .dop file and see the other changes I made (not that many).

Screen Shot 2021-11-03 at 12.44.02

I prefer Wolfgang’s explanation - the Devil did it!

You need to right-click on the app and then authorise it.

I tried right clicking on the above message, and I tried right clicking on the file in my downloads folder:

I don’t see any place to authorize it???

Probably best if DxO downloads my files, and replicates the issue on their test computers.

Sorry, I meant right-click then choose Open, then you should see the authorisation dialog.

I’m closer, but not sure what to do next?
If I click OPEN then I get the error message I posted. Or, I can click “OPEN WITH” which gets me here:

I suspect it wants me to open it with TERMINAL.APP but that’s just a guess - and if it does open in TERMINAL.APP, what do I do next?

This may or may not be related to the DeepPRIME issue. My Apple ScreenSaver used to show my photos, but on two of my Apple computers, that is now broken. A screensaver showing “glowing patterns”, or whatever, designed by Apple works fine, but when I try to use images, I get an all black screen. I told the tech I was talking to about XPCCort, and he was aware of it. He told me my screen saver issue would be corrected in an update.

Who knows - maybe this is related to DeepPRIME issues? I’m just wondering out loud…

If human help is not fast enough here is the official howto :grinning:

I only use the method described in the note.
Sorry I am not on my Mac so no screenshots.