DxO Nik version 4 install fails on Windows 10

Yesterday I bought the upgrade from DxO Nik version 3 to version 4. I downloaded the installer. It went 98+% of the way through then failed. Today I re-downloaded the installer, tried again, and got the same error.
DxO error 1
and then

Have you checked that nothing is running (even if you haven’t opened) as some run, or processes that are part of a program at Start Up even if you haven’t launched the program e.g. Affinity, Photoshop, Lightroom etc?

Try looking in the task manager and killing any graphics processes then try again

I suggest opening a support ticket at support.dxo.com. They will know how to figure this out.

Have you seen This post?


  • I have checked that nothing else is running, using the Task Manager. If something else other than the usual background processes and services is running, I wasn’t able to detect it.

  • I may open a support ticket. However, they obviously monitor this forum, and given the multiple complaints, it should be obvious to them that this problem exists.

  • Yes, I’ve seen the linked post, and two or three others. FWIW, my computer and DxO installation are English.

  • I’m skeptical that this is substantially a Windows problems instead of mainly or solely a DxO problem because the update from PhotoLab 4.2.1 to PhotoLab 4.3 installed fine, as did the latest Firefox update, as did the update from Windows 10 Home version 20H2 to 21H1, and did two or three other Windows updates. In short, everything else, including another DxO product, updates fine.

  • I’ve got a parallel thread at DPReview: https://www.dpreview.com/forums/post/65201411 .


I have the same problem. I can’t install the Nik Collection version 4. The screen reads that application has been completed, yet it is not in my hard disk. I am confused. Can you guys help me? I am using Windows 10 Pro 64 bits.

Welcome to the forum, Epiac.

I recommend you raise a ticket via DxO Support (click here) … and/or read here.

John M

If you set the Windows language settings to English (us) log of and on > start the installer and install and then reset language to your preferred and log of and on again it should work- did on mine (Danish windows)

1 Like

As an update:
I submitted a support request to DxO, at the main website. That was about a week ago. DxO had me download and run a little diagnostic program, which compiled a ZIP archive of data to send back to them. I compiled the archive, which came to 1.4 GB!

DxO gave me a URL to get back to the support ticket. I have followed that URL both with, and without, first logging into DxO’s website (not to this forum, but to my account, e.g. that shows the products I’ve licensed), and I have tried the usual login → return to my existing support issue. In all cases I get this error message:

This page is temporarily unavailable.
The follow-up and the processing of your request will be done by email.
Please submit your request to us by contacting Customer Support via our contact form here.

I even tried to start a new support ticket, but it would not accept the upload of the 1.4 GB ZIP archive.

So at the moment I am unhappy with DxO and its buggy support of its buggy installer–and I say that as a long-time, mostly happy DxO customer who has bought multiple products from them and usually bought each update. Hopefully they will fix it soon.

1 Like

Another update

I got the message to uninstall all Nik versions (already happened when I previously tried to install Nik collection 4), clear the brower chache (set to happen automatically when I exit Firefox), download from my account (now version 4.0.8 instead of the prior 4.0.7), and it should work. I’ve now tried this twice, and it fails just as it did before. Grrr.

I have the same problem.
Unfortunately, I couldn’t switch to English and install it either.

Deactivating the firewall and Win Defender did nothing.
Installing in Admin did nothing.
Installing in Safe Mode also did nothing.

I uninstall Nik Collection with Revo uninstaller.

Version 3.3 works without problems. :slight_smile:

If I update from 3.3 to 4.1.1 it doesn’t work either.

Ticket is already created 2x. Log is also sent. ( Since about 11 weeks ! )

There are several things that need to be checked in order to fix this problem.

I suggest starting with Windows.

If you run Windows Update, do you see any packages that are available to be installed? Either recommended or optional?

Are your network adapter drivers up-to-date?

How much free disk space do you have? RAM? And how big is your Windows pagefile? (Right-click on Start, select System, then select “Advanced system settings” → Performance “Settings”… → Advanced tab.)

If you open a PowerShell as Administrator and run the command “sfc /scannow” do you get an error report? If you do, and sfc couldn’t fix the errors, follow these instructions:

How to use DISM command tool to repair Windows 10 image | Windows Central

When you know that Windows and your drivers are OK, try downloading the Nik Collection installer software using a different web browser or download manager than you’ve been using. Some download managers (built into web browsers or installed as add-ons) are notorious for corrupting downloads or streams if the network connection is turbulent. Try Edge - I haven’t had as many problems with that as I’ve had with Firefox and some others.

If the problem still happens, I suggest obtaining a program that generates MD5 checksums. Run it against the Nik installation program (version 4.1.1, the current version) and post the checksum here so that the rest of us can see if it matches what we have for Nik 4.1.1. If you don’t want to use MD5, you might be able to right-click on the Nik installer and select a CRC checksum method, which will display results in a small window. Please copy and paste the whole result here.

Best wishes.

Here is the MD5 code:

There is now version 4.2.0 , which now works for me and can be installed normally.