Nik collection 4 still won't install, x-0643 error

Has anyone ever found a fix for the widely-reported Nik Collection 4 failure to install with the 0x80070643 error?

I bought the update right after it came out, and started a prior thread about its failure to install ( I have never found a fix. At one point supposedly a few version fixed some failures, but I have tried multiple times with newer versions, including three or four times with the latest version (, and each time it gives the same error message after reaching 99% in the progress bar.

FWIW I can reinstall Nik Collection 3.3 just fine. But I want Nik Collection 4, which I paid for.

Yes, I started a support ticket and did what was requested. The system would not let me upload the huge trove of data (1.4 GB!) the the diagnostic DxO sent me to run harvested from my system. I am extremely frustrated with DxO.

Where is this problem widely reported?

A 1.4 GB zipped archive is enormous. :flushed:

See your prior thread for some more suggestions about fixing the problem. Post the results there, please. I won’t be following this second thread.

Good morning @NAwlins_Contrarian ,

I’ve made a test installation and the whole Nik Collection install is about 1.97 GB

What did the guys from DXO aks you for uploading?

best regards

and maybe you can take a look at the Logfiles.
Read it from the end or look inside the files for words like error aborted rollback

In the first shown logfile a exitcode with 0 show succesful installation
[025C:0DDC][2021-09-16T08:55:13]i007: Exit code: 0x0, restarting: No

My install problem is a bit different. Try and install Collection 4 and it abruptly terminates with “reboot required”… which is then a never ending loop. Can never get beyond that.

I have been dealing with DXO support since I paid for it in June…

They don’t seem to have it figured out.

Trying to uninstall it does not work, same issue.

Coll 3 is fine. Coll 4 is fine on my laptop (both Win10). Reinstalling Col 3 works, but I paid for a fully working Coll 4.

BTW, the huge diagnostic zip file contains all your monitor/printer profiles. It’s not obvious to me why.

They will send you a link to upload it (they refuse to use 3rd party FTP sites).

DXO’s insistence on removing previous versions is a pain, any serious user keeps the previous version until the new is proven.