Disappearing labels

Hi there,
I’ve downloaded a trial of Photolab 4 and found a few issues, not show-stoppers but annoying.
I’m experiencing missing/flickering UI elements. It is visible nearly everywhere, e.g. menu positions/elements in different UI sections. See the screengrabs below

The counter is flickering, and while the counter is going, it shows a weird background. Next to it are two buttons/links to Nik Collection and Export to Application, but both disappear when you hover on them.

on the screengrab below, the menu elements are missing

I run the software on a laptop with NVidia 1070 built-in with the latest drivers installed.

I tried enabling in preferences use of OpenCL for Display and process, but that doesn’t help.

Anyone else experienced this problem and by chance know how to fix it?


Good morning @Protazy and welcome to the forum,

It seems to me you’ve got the problem similar to this one -Display bug with DXO PHOTOLAB 4 Elite on win10

Could you please, check if you have one of that apps installed?

Thank you
Svetlana G.

Indeed that was it! I had Sonic Radar preinstalled on my PC. Uninstalled and all works OK now. Very weird bug, thank you for your help.


1 Like

You are welcome :slight_smile:

Svetlana G.