DeepPRIME XD introduces purple overlay/chromatic aberration

Oops! My bad. I did not restart the application in between. Still slightly odd in that the second run I did was clearly quicker than the first, while still using the neural engine.

Anyway, I have re-done the tests on the five images.

My photos all had DeepPRIME applied and to export all 5 took 17 seconds with NE and 58 seconds with GPU. I can definitely note a colour difference in this photo. The yellow in the centre of the flower is obviously different when I flick between them with QuickLook and I can also detect the paler parts of the blurred grass change.



Then I switched them all to use DeepPRIME XD and re-ran again. NE = 54 seconds, GPU = 217 seconds. The colour change seems the same to me.



It’s a subtle difference in this photo (and even more so in the other four) but it is definitely there.

Thanks for the clarification, @Winkie. :slightly_smiling_face:

I’ve been out in the back garden trying to catch fast birds in flight. I got one sharp image, and plenty with the whole bird in the frame. Those two sets did not overlap. :roll_eyes:

Anyway, I’ve come inside to process some perched bird shots and noticed a distinctive colour change in the DeNoising preview, between DeepPRIME and DeepPRIME XD. I should note that I have turned on wide gamut.



Once again, it is subtle, but very obvious when flipping back and forth between them. I think the most obvious place to see it here is centre right, where the distant foliage has a richer tone in the DeepPRIME version. But also it is noticeable in the green sheen on the black feathers, which appears more blue in the XD version.

I think this is the same issue as stated before. The color shift, when using DeepPRIME XD in combination with the Neural Engine supported export, seems to affect mostly darker areas. For example, the beak tip has a slight violet tone in the 2nd image.

Here is another sample with DeepPrime XD

1 Like

1 Like

Hello guys,

First post here to Samy I m not disapointed With this community : I have encountered this very same issue, for the same reason. It drove me crazy because I had just bought PL6 (after multiple tests on M1), and just update the M1 to ventura, and was treating my first wedding shoots With my new R7…I mean, what could go wrong, right ?

Anyway, thank for your research and the workaround, I will manage to make my client happy finally, but this is an issue that need to be adress as soon as possible, and I trust the PL magicians to do so :slight_smile:

1 Like

Hi there and welcome Jimmy.

I know problems like these are not what one need when doing delivery for a customer. :frowning:

The DxO team will sort this swiftly as they usually do.

When it comes to production environments - one should refrain from making any changes to a system in the middle of a delivery.
And if forced to do so, a parallel stable and non touched system is to recommend. Even though one might be able to revert back to a previous setup if an update goes awry.

Hello and thank you for your awnser, I fully agree with everything you said ! I should have known this better, but I ve got carried away by my enthousiam (for information, I am an informatician, and a photographer for many years now)…So, I put myself into trouble, and your advice are exactly the one I would have give to anyone stupid enough to do the same error I did :p.

Anyway, one reason I purchase PL (and slowly abandonning LR) is that I have full confidence in the DXO team. Moreover, those kind of issues are impossible to detect forefront, so comprehesion should be mandatory :slight_smile:

Hello Everybody
The issue is acknowledged by our teams and will be fixed in an upcoming release.


Thank you so much.

On my M1 Ultra with 48 GPU cores, setting parallel export to ‘12’, DeepPRIME XD and optical corrections:

  • Neural Engine, 16 images: 289 seconds
  • GPU, same 16 images: 358 seconds

That’s great! Thank you for that. Have you any idea on how many time it will take to release this update?

Thanks again,

I just encountered this too. For me on at least one photo, though, it’s more than just a purple tint on DeepPRIME XD, it also added a checkerboard pattern in one area of the photo, Note in the upper-left where it added the pattern (in addition to the tint). Left is with GPU, right is with neural engine.

Did you up the number of parallel exports to 48 or some other respectively high number for GPU ?

It doesn’t go higher than 12 for me, regardless of which mode I select.

I get a similar pattern when using NE, but it’s not a simple checkerboard, it sometimes curves into a circular pattern.

I ran into issue with all photo exports from DXO when Using DeepPrime xd, anything DeepPrime gives me a checherboard pattern that follows a dome look to it and a color cast over the entire image. DeepPrime gives me a green color cast and the DeepPRIME XD gives me a purple colorcast. Prime works fine and High Quality works good.

I didn’t touch the parallel exports setting

Version 6.0.3 build31 is out… but nothing has changed!