"Correction Review" Keeps Sticking

Had V7 for a few days now and love the new features. But it keeps sticking with the Correction Review wheel spinning round. I have to Quit Photolab, which doesn’t actually work, so then have to Force Quit it. Reload and it’s fine for a while, until I have to go through the same loop again.

iMac 2020 4k
32GB Memory
Processor 3.6 GHz intel core i3
Runing Venture 13.6

Please anyone else have the same problem, or have a possible solution?

Cheers John


Exactly the same problem here, on Apple silicon so it definitely isn’t an Intel-only issue.

I’ve tried reinstalling PL7: it made no difference.

I’ve tried uninstalling FilmPack 7: again it made no difference.

The only workaround I’ve found so far is to reinstall PL6 and use that… (I downloaded PL6 from the link DXO sent me by email when I purchased it – I was pleased to discover that it got me the most up-to-date version PL6.11.0).

Unfortunately it seems that PL6 cannot read .dop files written by PL7, so the edits I made with PL7 are lost, but at least PL6 doesn’t hang every few minutes :slight_smile:

My setup is an M1 Max Mac Studio running Mac OS Sonoma 14.1.1

I intend to open a ticket with DXO support but haven’t got round to it yet… Good Luck!


1 Like

Thanks Andrew, relieved it’s not only me - I will fire up a ticket for DXO and see what happens.

I do have V5 if it gets too much, but I love the new features and what to use them…

Cheers John

1 Like

I haven’t had any problems with PhotoLab 7.1.1 for Mac (support for my camera was broken in 7.1.0 however), but thanks for the reminder to save old installer files. I went through my mail and downloaded both Windows and Mac versions of PhotoLab 6 and 7, FilmPack 6 and 7 and ViewPoint. Just in case I will ever need them in the future and the download links stop working.


no problem with PL7 or FP7 on Mac here.
maybe after installing PL reboot your computer and see if it happen again.


Thanks Mike, yep tried that more than once :slight_smile:

Same issue PL 7.1.1 on intel and M1 chip machines here.

Prior version was ok.


Same here.

Mac Studio, Apple M1 Max, 64GB memory, macOS Sonoma 14.1.1

I’ve uninstalled, PL7, FP, Nik Collection. Rebooted the Mac, Reinstalled the DXO software - problem persists.

1 Like

Just a thought. Have you given pl the needed permissions to access the volumes on which the photos are stored?

1 Like

Thank you for your suggestion Required. I am using a Mac Studio and all of a sudden this problem has developed after updating Elite 7.1.1 to the latest Build 38. I am quite new to Macs so their ways are still mysterious to me. What I don’t understand is that this build worked fine for about an hour and now I continually get Correction Preview and its wheel spinning and the app freezing - it is now totally unusable. As per your suggestion I have tried to check access permission so I have gone to System Setting > Privacy & Security > Files & Folders and DxO is there but has only access to the Desktop Folder while my photos are on the solid-state drive. I cannot find a way to grant access just to a folder on that drive. It would appear that I must go to System Setting > Privacy & Security > Full Disk Access and add DxO PhotoLab there. I do not particularly want to do this as this gives access to all my information on the Disk. Does anyone know how to grant access for DxO just to one Folder on the Disk?


I guess it does because it works ok, then suddenly you select an image and the wheel of doom just keeps rolling and you have to force quit and restart. Thankfully the restart doesn’t take too long but the whole process does throw your editing rhythm all to cock!

Thanks Gary, hopefully the DXO wizards are hard at work sorting it out :+1:

If like me it works fine for a while then locks up, I guess it’s not permissions or you wouldn’t see the images in the first place.

Same issue only appears in Local Adjustment.
Reported to DxO.

Mac Studio M2 Max 32GB Ram
Sonoma 14.1.1

1 Like

I am getting the same issue and have to force quit. It is now pretty constant and PL7 is becoming unusable. I have also had random crashes and lock ups. Am on the latest PL7 build - M1 iMac

1 Like

are those issue happening when you zoom in the picture or general preview?

1 Like

I first noticed it on a zoom in but it has happened on a general preview I believe. I’ll keep a watch on that.

1 Like

Just had a reply back from Seth (DXO) he says to ensure I have the latest version, which I have.

Also, please go into the program preferences and try resetting the DeepPRIME acceleration option from ‘Auto selection’ to ‘Use CPU only’ to see if this has any affect on the problem. (this is under the advanced tab) – success this appears to have solved the problem - hurrah :slight_smile: :grinning: :grinning:

But surely doing that will create the new problem of very long export times, taking minutes rather than seconds?

I spoke too soon, it stuck again after about 20 minutes :frowning: