Cannot export PL 5.1.2 to Nik Collection 4 Dfine2

I was trying to export a JPG file from PL v5.1.2 to Nik Collection Dfine2 Version x64 (v4.3.0) as a TIF (16-bit). PL5 created the TIF file but Dfine2 could not open the file because the file format is not supported. The TIF file was displayed fine in PL5 and can be opened by other NIK Collection products (except Dfine2).

I tried again by exporting the JPG file from PL v5.1.2 to Nik Collection Color Efex Pro 4 Version x65 (v4.3.0) as a TIF (16 bit). The file could be opened and edited in Color Efex without any problems. I saved the changes in Color Efex and then exported this TIF file from PL5 to Dfine2. Now, Dfine2 was able to open the file only after the file was modified by Color Efex.

I tried to export a Nikon NEF from PL v5.1.2 to Nik Collection Dfine2 Version x64 (v4.3.0) as a TIF (16-bit). Again, PL5 created the TIF file but Dfine2 could not open the file because the file format is not supported.

Any clue?

Not yet. Can you share the image files that have said issue for the rest of us to test with?

Tested, on macOS, a few of my old tiff and jpeg files, with and without converting to tiff first. All images opened in Dfine without any issues.

Exported a noisy NEF a JPG (sRGB),
used this JPG to produce a 16bit TIFF,
which then I could open, process and save in DFine2 without problem.

PL5.1.2.4700 // DFine 5.03.101 (v3.3) *)

*) re-installed Nik Collection v3.3
Issues with Nik4 - #8 by Wolfgang

I uploaded the following files to

I tested these files using PL 5,1,2 and PL 5.1.1 and the issue happened on both versions of PL5

@alee, the upload server cannot be read from the forum, but you could attach the files to a post. This should word if you’re not really new to the forum.

I am new to the forum so the forum does not allow me to attach any file.

After more tests, I found that this only happened on those JPEG files that were modified by exiftool. When the original copy of the same files were exported by PL 5.1.2, the corresponding TIF could be opened by Dfine2 without any problems. The same issue also happened with PL 5.1.1.

This is what I did:

  1. Install Nik Collection 4.3
  2. Install PL 5.1.2 (clean install)
  3. Create a new folder and drop two copies of the same JPEG file there. Name them file1.jpg and file1_orig.jpg
  4. Use GeoSetter (the user interface for exiftool) to add a time zone to file1.jpg and save the changes…
  5. Open PL 5.1.2 and navigate to this folder.
  6. Open file1_orig.jpg and export to Nik Collection Dfine2 as TIFF 16-bit or 8-bit. The TIF is opened properly by Dfine2. Exit Dfine2.
  7. Open file1.jpg in PL5 and export to Nik Collection Dfine2 as TIFF 16-bit or 8-bit.
  8. The TIFF file was created.
  9. Dfine2 started but displayed the error message “The file file1_Nik.tif could not be opened because its file format is not supported”.
  10. If I export file1.jpg to Nik Collection Color Efex,save the changes then export the TIF to Dfine2. Dfine2 was able to open the file.

The same issue also happens with Nik Collection 3.

There is no issue when exporting Nikon NEF (with or without exitfool modifications) to Dfine2 (both Nik Collection 3.3 and 4.3)

I suppose that your change somehow compromised the file format - in a way that is not tolerated by Dfine. Can you edit the modified file inother apps?

Please share the two files with a sharing service. Looking into the files could help to find the issue. Meanwhile, I’d recommend to not use the tool until we can be certain that it’s not the source of your issues.

I am now able to attach files to my posts but I think it’s easier to share the files from my Google Drive.

Here is the link to my files:

I have included the original and the modified JPEG file as well as the TIF exported from PL5. I was able to edit the modified file using Adobe Photoshop, Adobe Lightroom and Nik Collection Color Efex/Silver Efex/HDR Efex/Perspective Efx/Viveza. It only failed in Nik Collection Dfine2 and Sharpener.

Going to the PlugInSelector
and removing EXIF
Screen Shot 01-19-22 at 06.37 PM
then allowed to export to NC4 → DFine2 (still the old software)

Just yesterday I experienced …

My cam is a supported Lumix DMC-LX100. While I could export from PL5 to TIFF / NC4… and open that tif-file in PS, manipulate and even print, I could not save – neither as tif, as copy or as psd-file.

Excluding all metadata – didn’t check which one like with your example – solved the problem
(and also before, when I had opened / saved that tif-file in AffinityPhoto).

BTW, no problem with files from my Nikon D750.

@Wolfgang Thanks!. It works after I unchecked EXIF,

Tested the files with Nik as standalone apps as well as called from DPL5 (as is and as TIFFs). Result: All files opened in all Nik apps under all conditions. Tested on an 2019 iMac with macOS 11.6.2 and current versions of Nik and DPL. :man_shrugging:

@platypus Did you try the TIF files in my Google Drive. I am using Windows 11.

I downloaded the file, unzipped it and got 2 jpegs and 2 tiffs. All of these files opened without any hiccups in all Nik apps, be it standalone or launched from DPL (latest on Mac)

This is good to know. I downloaded file1_modified_Nik.tif to confirm that Dfine2 still gave me the same error message. I suspect that this issue only happens on Windows (or only on Windows 11).

I downloaded file1_modified_Nik,tif to my MacBook Pro and I was able to edit the file using Dfine2 there. It seems this issue only happens on Windows.