Attach ICC sRGB profile to exported image

As discussed in a post here and previously requested here. Note I am on Windows.

I have found that if I export as default ICC Profile sRGB, no ICC profile is attached.
If I specify a custom profile of “sRGB Color Space Profile.icm” no ICC profile is attached.
If I create an ICC profile from an image exported from Nikon NX Studio and then export and specify this new profile as the custom profile, it is exported with the image.

I have no idea if exporting with this Nikon profile actually impacts the image, and therefore I do not consider it a good workaround.

Request: When exporting to jpeg with sRGB, allow the appropriate DXO ICC profile to be optionally attached to the image.

Copied over from https://forum.dxo.com/t/colours-upon-export-to-srgb/36370/36:

I was also having this strange irritating issue and managed to find a solution.

I also was having color mismatches I traced to the cause of the srgb profile not being embedded. Come on DXO.

In irfanview, as others have stated, one can choose to have untagged images be presumed srgb, and this would display them correctly. However, this breaks other images, so isn’t an option.

What I found is that if you download the “srgb2014” file from https://www.color.org/srgbprofiles.xalter, put it in your color profile folder, and specify this one manually in your DXO export profile, it will embed and everything will work properly.

Hope this helps someone’s day! Cheers.