Why do I have virtual copies of all pictures with all the edits and ratings in the copy but not in the original file?


I´m using version 5 of PL on a Macbook Air.
Because of the limited space on the harddisc I usually move all my raw files to an external disc after finishing my work. When I need them again, I copy them back to the internal drive.
After copying back now I have virtual copies of ALL my pictures in a specific folder. All the master files have no correction at all, neither do they have the ratings I gave them.
All of this (corrections AND ratings) are made on the virtual copy. For every single picture…resulting in, at least, the double amount of pictures in the folder, which is an absolute mess!
How to get rid of this sh…y behaviour?

Unless you delete the database before opening images moved back into an old folder, PL will notice that the image has been edited elsewhere and create VCs to avoid overwriting any edits that might have been made in the original folder.

Alternatively, instead of moving the RAW files to an external disk, with their DOP and XMP files of course, you should copy them and then delete them from within PL. This will avoid having to delete the database.

Addenda - Get yourself an external USB-C SSD. They are fast and you can edit directly on them without having to keep on shuffling files.

1 Like

I’ve been doing this for a few years now. I highly recommend the Samsung T5 or T7 series. They’re so small and light you can pop one in your pocket and take it with you so you can edit anywhere.

I went for these G-DRIVE™ SSD | Western Digital

I have a LaCie Portable SSD 500 GB

@Joanna but arguably the images have not been edited elsewhere!?

The problem with the existing strategy and the one being proposed is the risk to the one copy of the data unless multiple copies are kept, albeit to a slower (and cheaper) drive than the one being proposed for the main edits.

I managed to “reproduce” the “symptoms” of the the problem on my Win 10 machine but if @DAnschi “insists” that what I describe could not have happened then we have a “mystery”.

Test procedure - AS(OFF) throughout the tests:-

  1. 4 images in a directory, 2 JPG and 2 Raw in this case.

  2. Edited including metadata but with AS(OFF) in this case.

  3. Images and DOPs etc. “moved” to another directory (i.e. do not move but rather copy and paste and only delete when sure the copy etc. has worked)

  4. The empty directory was then “discovered” in PL5.6.1

  5. and then re-discovered with just the original images present, i.e. no DOPs.

  6. the original backed up data was re-instated, over just the images, and the VCs appeared exactly as stated by @DAnschi

Initial Editing:-

2022-12-31_180833_Initial editing

Empty directory after “move”!:-

(Re)-discovering original images:-

Re-discovering after copy back of images plus DOP etc.:-

@DAnschi to resolve the problem (I hope)

  1. please first ensure that the images and DOPs etc. that you originally moved are still available intact on the backup media!

  2. Navigate to the original folder with the unwanted Virtual copies

  3. Rename the directory e.g. “name”-OLD

  4. Copy the backup i.e. the images, DOPs, sidecar files etc. from the backup media to the original directory and navigate to the directory in PL5 and hopefully everything should be back the way you want it to be!? i.e. clear the failed restoration from the database (by renaming) and restore again!!

  5. Remove directory “name”-OLD when happy that the new process has worked!

PS:- I do not know what commands are available on the Mac but I am sure that you will tell me!?

In fact @platypus had told me elsewhere that renaming via DxPL on the Mac is actually not possible

So a revision to the “recovery” strategy is needed!