Where to go fo r refund?

I’ve tried a dozen times to get help., but it’s just not happening. I am going to call my credit card and tell them to cancel paying for this NiK collection 4 I paid for a couple days ago. I have a brand new windows 10 PC. Very few programs are loaded. Nic will not load, says I already have a version loaded. Scan with everything I have, no versions are installed.
I loved the trail version on my old computer, so let me know when you get this working. But I refuse to pay for this.
Maybe in the future, before you send out new versions, test them. Set up a group of people with different systems and let them find the bugs. Do that a few times, as you probably mess up one thing fixing another.

Try the following:

  • download a fresh installer from your account in shop.dxo.com
  • uninstall the Nik Collection using the fresh download
  • reboot
  • Install the Nik Collection from the fresh download
  • find the NiK Collection folder and open all apps - one by one
    → enter your license key if prompted to do so
  • quit each Nik app that is open.

If issues persist, Submit a request – Customer Support
Also consider to check out Nik Collection by DxO: User Guide

Also, since you’re having installation problems, it’s a good idea to temporarily disable any antivirus/antimalware software, just in case it’s interfering. I don’t know what else could cause what you’re seeing. If the problem persists, can you post screenshots and explain the steps you’re following up to the point the install fails?

Hello, I have downloaded a fresh installer a few times. Still will not run. Here is a screen shot:

There are no other versions running.,
The first popup says it is already installed. The second popup is after I try to run it again…
I’ve submitted 3 requests. Never got a real reply. Only get a form letter saying they have received my request.

What are you referring to when you say “installer”? Are you talking about the executable?

I download the .exe. Then run as admin. That’s it. The popup screen telling me a version is already installed happens almost immediately.

I think I fixed it. Before moving my files to my new PC, I had saved NIK 4 to my thumb drive. The .exe files were much larger than what I downloaded from NIC a few days ago., I moved these to the new PC, and they started right up, Did not need to do an install. So I assume the installer has issues.
Just to verify I have the latest and greatest, I have Analog Efwx pro 2, Color Efex pro 4, Dfine 2, HDR Efex pro2, Perspective Efex, Sharpener Pro 3, Viveza 3, and Silver Efex Pro 3. Is that correct?

Yes, that is correct.


1 Like

I have a question for @pallenth. How did you mark your post as resolved? I have wanted to do this before and cannot find how.

1 Like

There is a box just below your post that has Solution next to it. Click that box…