What stops thumbnails from building?

I have a lot of thumbnails that don’t build unless I click on them. That is unacceptable for photo processing software, of course. What is preventing them from building? Am I missing something in Preferences? Cache is at 1000. Using under 800 now. I have a new mac mini with plenty of RAM and processing speed. I am using Monterey OS.


1 Like

I dont know whats stopping the thumbnails from building, but I hope you have tried a simple Refresh in the library?

@tpytlarz , what is it that you see on screen insted of a thumbnail? Can you add a screenshot?

I’ve just been getting the same thing with PL6.1 ( on Windows 10 ). Some folders load up fine but then a couple have had the same problem - some of the thumbnails in a folder do not load, just saying “Loading, Please Wait” and I have to click in each one to get the thumbnail to load.

Until the 6.1 update there was a problem with the thumbnails not loading anymore more after about 930 ( either one or multiple folders ) until you restarted so I don’t know if this is related.

Sorry, platypus. Meant to upload my screenshot when I posted. Additionally, they don’t ever load. It’s not a matter of waiting - which isn’t a solution anyway.

Also, in some other folders, some images appear but they have the circular arrows on them.

You’ll also notice in this screenshot a couple of question marks. Those are HDR dng files I created in DxO. When I click on it it says, “This image cannot be processed since it was taken with a camera that is not supported by this version of DxO Photo Lab.”

If you have “Preferences / Display / Preview quality” checked, it may be causing your display to overload.


I have a few questions that might help to find the source of your issues:

  • When you switch to a different folder and back, do the thumbnails appear?
  • Do the images display in other apps?

Sometimes, a little change can throw DPL off its track. PhotoLab is also very picky in what it will handle and images that have been stitched, stacked etc. will mostly not display, I have no other app with such limited appetite.

One way to deal with such a situation is to delete DPL’s database and cache files. You could try this after having made a backup of the DB file. You’ll find the files in your user account’s Library folder, which is hidden by default, but can be made visible.

While I’m on Windows, I had something similar.

Moving those thumbnails to another folder, re-indexing and moving back to the origninal location seemed to solve it. :slight_smile:

LarsN. I checked off the preview quality as you suggested. Problem solved! Wonderful. Thank you.


1 Like