Virtual Copies created when copying file folder from one win pc to another pc

I have DXO PL3 Elite version (version 3.2.0 build 4344) on a windows 10 Pro desktop and a windows 10 Pro laptop. The problem that I am having is that when a file folder of Nikon NEF images has been keyworded and Star rated on my desktop is copied to my laptop, I get virtual copies of all NEF files when I look at the images in DXO PL3 on my laptop. I have not tried to create a virtual copy of any NEF file or create a collection.

The file folder originated on the laptop. It was then saved to an ex hard drive and copied to the desktop. Then worked on on the desktop. Then put back onto the laptop.

When I delete the file folder from my laptop, reboot the laptop, and copy it again to my laptop from an external hard drive, I get MORE virtual copies of each NEF file. Most NEF files show M for Master and 1 and 2 for virtual copies.

I have no idea what is causing this but it is driving me crazy and makes it just about impossible to use two win 10 pcs with DXO PL3.

I have not uninstalled DXO PL3 yet from either pc as I wanted some advice first.

I used a different external hard drive and the same problem occurs when I use it on my laptop.

I even reformatted the ex hard drive but that did not fix the problem.

According to Nikon software there are 499 NEF for raw files in the file folder. on the laptop and ex hard drive. DXO PL tells me I have 1549 images on my laptop file folder and 816 images on the file folder on the external hard drive.

What do I need to do?

Is there a specific workflow for windows users using two pcs to avoid these kind of problems?

I have already discovered that keywords are not saved in the file folder with the images so keywords used on one pc cannot be transferred to another pc.


You might want to try this:

  1. Set DPL (each version on each device) to not automatically export and import sidecar files.
  2. Manually export sidecars before you move the folder over to the other PC
  3. Open the freshly copied folder on the other PC
  4. Manually import sidecars
  5. Continue working
  6. Do as in step 2

CAVEAT: I test (on Mac) with one folder and several versions of DPL and never get virtual copies. My case differs from yours but you might still want to test if the procedure above works in your case.

DPL is designed to work with one database only and does not have any idea that other DPL-databases exist until you do what you do. Then, DPL creates virtual copies in order to preserve what you customized before the copy/move. DPL has no database sync features, but you can “sync” the databases with the proposed procedure.

When you look at your image folder, you’ll notice that it contains one sidecar per image, no matter how many virtual copies you have. All info about the VCs are in the sidecar files. When you import a sidecar that has no VC info in them, the VC(s) go away.

Are you copying the files while PL is running?
I’m working on 2 pc and synchronize them through a nas but I never do that when PL is running.


George, I am pretty sure that DXO PL was not running. I copied the file folders in windows explorer.


I reread your post. You’re adding keywords and ratings to the image. Beside the problem of your virtual copys, the keywords and ratings are not added to your image or dop file.
Do you overwrite the older files or not?


George, my understanding from DXO Support is that the keywords are added to a database somewhere and are not added to the xmp flie or the dop file and that means they do not transfer when the file folder is moved to another computer.

In my case, the Star Ratings that I make on my desktop somehow stay with the image (DOP File?) as they do show up when I view the image in the copied file folder on the other computer, in my case the laptop. My desktop has dual monitors one being a 30 inch monitor. I much prefer to do the Star Ratings on it rather than my 15 inch laptop. When I do the star ratings I often delete images copied from the laptop.

On my laptop the images and DXO PL programs are all on C drive., an SSD drive. I believe the keyword database is on C drive too. (Preferences tells me the database is on drive C.) When I copy the file to an external hard drive, the drive is usually D.

On my desktop, the images are in drives other than C, like -D, E, etc. I prefer to keep all of my images on spinning drives and reserve my C drive for programs as it is a SSD drive. The external hard drive is usually F. DXO PL3 and NIK Collection is on C drive.

The database is in c:\users\your name\appdata\roaming\dxo\dxolab3\database. Every installation has it’s own database. So what’s stored in pc1 isn’t stored in pc2.
Maybe you should have a look in your settings. In PL edit-preferences-general-correction settings. Mine are set to save and load in/from sidecar files. And no problem with copying.


George, I will check Preference settings to see if I can get keywords added to dop or xmp files. And I guess I need to submit this matter to directly to DXO Support as they have not responded.


You misunderstood me. I was referencing the problem with the virtual copies.
Keywords are in the database, in your case 2 different databases. Rating I don’t know, I never used it.
Try to add the keywords to your nef and forget PL. I don’t know what Nikon you have but have a look if your camera is supported by ViewNx2. Otherwise you could use Geosetter as I read here. They add the keyword to the raw file.
The next problem will come when you export the image. The keywords are written in the xmp section, not in the iptc section.


Hi Joseph - - As others have advised; your problem arises due to there being a version of the database on each machine ;

So, there are two workarounds that might suit you, depending on your set-up.

  1. When you copy your {image + sidecar/.dop} files between your laptop & PC you could copy the database file(s) across too. You’d need to be careful and diligent about this, tho.

  2. A better solution: If you have a storage device that both your laptop & PC can access at the same time - then you could go to Menu item: Edit / Preferences and, on the “General” tab at the very bottom, change the Database Location to a folder on your shared storage device.
    – Note: You will also need to move the latest copy of the database (from either your laptop or your PC) whilst PL is NOT active, and before you restart PL on either device.

John M

I think copying the database is a bad idea. Beside that there’s also a cache where PL makes use of.
Regarding to keywords the only solution is adding to the raw file. Even when using a program like IrfanView browsing the raw files you can make use of the keywords.


Copying the database to and fro is probably the only way to go. As for cache, you can include it when you copy the database, but it is not vital. I’ve deleted the cache (on Mac) many times without having issues with DPL apart from the fact, that DPL will recalculate previews and create new cache files.

You could create a batch/script that copies database, preference files, image folders and cache files, once you have verified that copying the things will actually work. Make sure that all paths are the same on both machines.

1 Like

Just curious. Did you check the Preferences?


PhotoLab does not add keywords to .dop sidecar files.
PhotoLab does not write (to) .xmp sidecar files either.
Keywords are only added to exported files.

It’s about the virtual copies being created after copying to another pc.