Very slow download speed from DXO


Wanting to leave Adobe and their subscription model, and decided after reading several reviews weighing in the pros and cons, to go for PhotoLab over Capture One. Started the download last night, however now, after 13 hours, I still have 16 hours+ left - download speed is 5-6Kb/s.
I makes me worry about future updates and just the general support of the software. I am almost at the level of giving up on PhotoLab before even having installed it. Is this normal, or does DXO perhaps have some issues in their end? I looked at their FB page but found no info about them having some issues.
I am on a 1/1 Gb/s finer connection - so no limitations in my end.

Have others experienced the same?

No, this is not normal.
I just did a test and it took me 7sec.
Abandon and try again


Thanks - I tried that last evening, and ended up with the same result… Will try one more time.

That did the trick - seems like there have been some issue last night, now I downloaded in less than a minute.
Was just a little reluctant to cancel my download as I had spent 13 hours reaching 40% :wink:


Cool, all you have to do is use it, I hope your choice of DXO PL will suit you.
Don’t hesitate to go back here if you have any questions.