Version 4 Trial

Have version 3 but thought I would quickly trial V4 before upgrading. Is there any conflict doing this? Just thinking of how V3 and 4 sit side by side as plugins in Lr and PL.

Installing the Nik Collection will first remove an older version from your computer. You can install the new software to try for 30 days, but will need to uninstall it and then reinstall your older software if you don’t want to keep using it.

I tried it and it sort of worked as far as I’ve tested. Getting there is not easy though: You’ll have to rename all folders that contain stuff from V3 and install V4 in a folder with a custom name (and rename all other folders too) and then teach the apps which version to use.

My focus was on Ps/Lr rather than on PL though and I decided to stop following that trail because of all the hassle involved.

Thanks each

Foolishly I purchased, downloaded and installed Nik Collection 4; I was excited after watching the videos on the new Silver Efex 4. Collection 4 does not work at all and now I do not have the plug-ins from Nik Collection 3 to use on my main computer (Windows 10)
Choosing JPG in LR and editing in PS 2021. Made a duplicate layer. I can “see” 2 DXO filters (Silver Efex 3 and Viveza 3); for either Nik program I choose, a tiff is made but not opened. I get an error message: “Image format or size not supported by Nik collection” yet the JPG is saved as filename-edit.tif. I do not know how to uninstall Nik Collection 4 and return to Nik Collection 3 until DXO sorts this out. I am getting frustrated with paying $$$ to update my DXO Nik Collection products and have them not function. HELP… I need directions that are user (not tech) friendly to fix this mess. Thanks.

Georgette - I see you’ve posted to multiple threads on this same issue … and, I thought you’d acknowledged a successful solution (here) based on @Wolfgang’s suggestion … … No ?

John M

As I mentioned to Wolfgang: I successfully deleted Nik Collection 4 & installed Nik Collection 3 again. I ran Silver Efex Pro 2 first and DxO asked if I wanted to update to Silver Efex Pro 3. I declined. I have already paid for Silver Efex Pro 3 and Viveza 3, but I think that I will wait awhile before I take the upgrade. Others have had install problems so DxO is probably working on a “fix”. Gotta have hope!!!

1 Like

I too got this message originally - I was advised by a member here to Uninstall the Nik Collection and start again - Go to your computer Settings/Apps area and find and uninstall the Nik Collection, reboot and re-install the Nik Collection again and see if that helps… It cured some of my problems.

I’ve just realised @John-M has already drawn your attention to Wolfgangs original suggestion! DOH! :roll_eyes:

1 Like