Using the new LR CC plugin

Hi everyone,

I’ve just upgraded to PureRAW 2 and I’m now using the LR plugin and I’ve got a couple of questions.

  1. When I export to PureRAW 2 from LR, do I need to make sure that nothing is being applied in the Detail and Lens Corrections section? Or does PureRAW 2 know to ignore these and not duplicate that processing? I see these sections are blank when the dng is produced but I wanted to double-check.

  2. With my workflow I import images into LR and do minimal processing - like I make a few tweaks in the Tone section to help evaluate the image. Do I need to reset those before exporting to PureRAW 2? In the past I just dragged the raw file into PureRaw outside of LR - but now that I’m exporting again from within LR I just wanted to double-check.

Thanks for any assistance.


Hi there,

Photojoseph made a well detailed video about PR2, and specifically, all your questions are answered there. It’s here: UPGRADE! DxO PureRAW 2 — New workflows, FUJI support, and more! - YouTube


Many thanks - I’ll watch it now. Thanks again for the quick support - much appreciated!

PureRaw does not take Lightroom’s corrections into account, it works directly with the unprocessed raw files. To launch PureRaw from LrC, you have to use the module options:

After a while, processed images turn up and, as you can see, DPR has ignored the B&W I set in LrC and returned processed images in colour.

Note: Images processed by DPR turn up without further ado. They are also shown in a separate collection. DPR creates a new collection with every job. After a few runs, the list of collections can get quite long (and annoying), but the collections or the surrounding folder can be deleted at any time. Deleting a collection does not delete the images within.

1 Like

Very much appreciated. Between this helpful info and the youtube video my queries have been resolved.

Thanks again. :+1: :pray:

1 Like

I was having success with the auto import process (it was taking a while for them to show, but I understand that’s just LR being LR), but now it seems to not work at all. I assume this error is related, are there any suggestions on fixing it?

Remove the plug-ins and start DPR as stand-alone app. It should then present a popup asking to install the LrC plug-ins.

I removed the plugins and reinstalled them as your suggested. It worked the first export/import. Second time - three hours later, photos not in LR, no collection added. The files have been processed, I can go find them in the allocated folder. They’re just not being imported.

Looks like something on your computer “eats” that plugin… What has happened in the 3 hours? User interaction, malware checker, backup…?

I had this issue as well, I just gave up on it.

My issue was … trying to get LR to import the files in a timely manner (too unreliable). So i have taken the “manual route”

On the round trip back from DxO to LR

  1. DxO i export DNG to current folder
  2. Go back to LR and “synchronise” the folder in the library. It should highlight how many “new” files have appeared in the directory.
  3. I then colour tag the new imported files from DxO
  4. I can synchronise my edits for each photo or just finish off my edits in Lightroom

In those few hours I was using LR and editing other photos, and then watching tv. However, I noticed today (after a couple of restarts) the plugin seems to be working again. The LR import is still rather slow and lagging, but generally within a few minutes of DxO finishing the processing, rather than hours.

Similar to what I’ve been doing (and was doing on the previous version of the software). I just let it spit them out to a folder and synchronise the folder after it’s done, rather than relying on and waiting for the auto import.

1 Like

During tests, I noticed the following:

Roundtrip from Lightroom Classic (current version)

  • after processing has stopped in DPR, Lightroom sees the first image after about 15 seconds and further images are added 1 image per second.

My current experience is, that Lightroom Classic shows the first returned image after <2 minutes and from then on, one image per 6-7 seconds with DeepPrime - under macOS 11.6.5 on iMac 2019.

Attn.: @DxOStaffPO
There is quite a discrepancy between what is shown by DPR’s progress bar and Lightroom’s Collections. The difference of 18 images corresponds to something like 2 minutes, consistent with the initial delay I noticed. What is keeping those output files from showing up in LrC?

1 Like

I run into the same trouble. My fix is using Jeffrey Freidl’s Folder-Watch Lightroom Plugin (Jeffrey Friedl’s Blog » Jeffrey’s “Folder Watch” Lightroom Plugin). There are a lot of possibilities to configure it and when done right it works like a charm. :cowboy_hat_face:
That’s my solution after the DxO Support told me it’s not a bug, it’s depending on the size of your LR-catalog …