Upgraded to PL 5.1 (Elite), now freezing periodically

Since I upgraded to PhotoLab 5.1 last night, I’ve suffered periodic freezing, from which it never recovers. If I export to Topaz Sharpen AI, then it will freeze everytime, but only after Topaz deposits the finished file.


Windows or Mac? And precisely which build?

Windows. The latest build (that I down loaded yesterday - and which is currently frozen again)

It’s freezing when I export to Nik as well (at the point it finished the Nik save)

Yep I’m getting fairly frequent freezing on the latest 5.1 version as well. Seems for me to occur while exporting (deepprime if that matters) and while navgating during the export. Older versions didn’t crash like this. No driver updates changed, nothing else changed. Just the 5.1 upgrade. My first crash was an hour or two after upgrading.

Windows 10, and Nvidia RTX graphics with gobs of RAM.

1 Like

If you’d like assistance, you may want to start your own thread. There you can supply specific informaton about your environment which is certain to be different than @Phossy 's

Windows? 11, 10, 8… build? (what @Joanna) was looking for.
I suggest:
Running sfc /scannow
Reviewing your Event Viewer
Reviewing your PL Logs for error information
Consider opening a case with support

If you aren’t crashing, I’m not sure what the logs will contain, but hopefully something meaningful is being captured when you perform the Export to Topaz Sharpen AI or NIK and the system freezes consistently.

I have no doubt I’m not the only one and I’m not looking for assistance. Just offering my info for developers.

I’m managing okay but I am confident this is not a me issue. Something has changed on the PL side. Perhaps it’s a set of specific edits that’s causing a problem or perhaps it’s something else.

I’ve had no crashes with 5.0x in a few weeks of heavy use and 4-5 crashes with 5.1 in a few days of similar use.


I understand. You’ve been around long enough and know how to receive assistance. Hope things improve.

Another user with a crashing PL5.1 Elite after upgrading to the latest version. Happens when exporting Pentax K-3 III files with DeepPrime enabled. Doesn’t happen without DeepPrime enabled or when exporting K-1 files with DeepPrime enabled. Didn’t happen before upgrading to the current build.

Good morning!

Guys, please provide your logs or crashlog if you have it:

Crash files – %UserProfile%\Documents\DxO PhotoLab 5 crashes
Log files – %UserProfile%\Documents\DxO PhotoLab 5 logs

Svetlana G.

I would if I was allowed to upload files or more than 30000 characters in a post

I responded to the email i got on this and Zipped the files. I have no idea if it got through, but there were no other instructions.

  • It means that you created a support ticket already, right?

Svetlana G.

[quote=“sgospodarenko, post:14, topic:23535”]
Then you can use upload.dxo.com
[/quote]Ok, that’s what I did.

Good morning @ehrwien ,

Well, from your logs I see you still use PL5.0.1 and this crash is expected. Please, update to PL5.1.0 #4690 and this crash should be fixed.

Please, try and let me know your results.

Svetlana G.

I upgraded on Sunday and PL tells me it is version 5.1 build 4690, and when clicking on “Look for Updates” it opens a window with “DxO PhotoLab 5.1 >DxO PhotoLab ist aktuell<”, so the version number in the log file must be incorrect. In fact, it does list the same version in both log files in several places: 2021-12-12 21:01:25.464 | DxO.PhotoLab.ProcessingCore - 9028 - 1 | DopCor - Info | DxO.PhotoLab.ProcessingCore version:

But I’ve not had the program crash on me for a few conversions today. I had rebooted the PC on Sunday after updating to exclude that as a possibility, but it didn’t work that day. Perhaps it does work now.

  • Okay, let me know if you get the problem again.

Svetlana G.

Regular freezings for me too ! Happens with 5.1.1, didn’t have it before.
it does not crash it just freezes and i have to kill PL in task manager.
3 freezing in 30mn
DxO.PhotoLab.txt (679,1 Ko)
update : new freezings, too painful, going back to PL4 while bug is solved

1 Like

Have you tried uninstalling it and reinstalling it? Or have you tried running a repair install?