Update Blocked

Latest update for Photolab 4 blocked by Windows Defender (win 10)

1 Like

Doesn’t it give you the option to “Run anyway”?

Yes I have the option to “Run anyway” but I’m the paranoid type and block anything suspicious. Previous updates were Ok.

1 Like

I have this every time.
Try to start the installation with right click and “run as administrator”

Yes, this should work.

Run as administrator same result. Reckon I’ll leave the tinfoil hat on a little longer.

This problem often happens with new software releases. It can take a while before antivirus programs recognize it as a legitimate release. If you trust the source, ‘Run anyway’ (I did). Otherwise wait a few days for the antivirus programs to update.

Note: You’d think that software companies could communicate in advance w/ antivirus companies to avoid this kind of thing, but apparently it’s more difficult than it might seem.


When I opened PhotoLab 4 Elite this morning, I received a prompt that an update was available. When I checked on the status of the download I had a message that the download was blocked because "it could harm your device " This was generated by Microsoft Defender SmartScreen as the download was done through Edge.
Is this something about which I need to be concerned? I’ve not had this happen with previous downloads for other iterations of PhotoLab.
Thanks for any help/advice that can be provided.

1 Like

This the first time I have seen this type of warning come up…I had no idea it was even running in the background!!!

I have kept the file and will do what I always do, I will check it with my AV software.

However, what has happened that it is being identified as a potential problem???

This happened to me with PhotoLab 4.1, too - and all I run is Windows Defender and Malwarebytes Premium. Defender’s explanation for the warning is that the application is rarely downloaded - therefore it can’t be trusted. Duh - it’s a new release! This kind of heuristic has stopped me from downloading safe files several times. If there’s a way to turn this heuristic off, it hasn’t been offered to me except case-by-case. And even after I permitted the download to be kept and manually scanned it, running it required that I again confirm that the file is safe.

Thanks, Gregor! I think you’ve solved it for me. It’s strange - Reputation-based protection appears to be turned off. There’s a button to turn it on. But if I click on “Reputation-based protection settings,” quite a few things are turned on. The setting to block potentially unwanted apps (apps with low reputation) is off. But above it is the setting you pointed me to, turned on.

1 Like

Good morning, guys,

It’s not PL but Windows that causes this problem many apps are now reported as suspicious - you can try to download and install Zoom or Slack for example and see the same warning. Please, follow the advice given by @gregor above :point_up_2:

Thank you,
Svetlana G.

I got this message too, (first time ever) but ran the download/install anyway, no problems. However, afterwards, when I came to move my desktop shortcut to its usual location on my screen, I found that next to it there was a shortcut to a notepad message of some sort, which I didn’t understand. I just deleted this shortcut. Was it a record relating to this security warning?

Guess what? Each time I install an internal build (like dozens of times each month) I get the same “warning” message. There is nothing to worry about, unfortunately malware and viruses are a real thing and companies like Microsoft “raise the bar” preferring to create false positives than the contrary…

You can safely install our update!

Thank you.

Thanks for the heads up on that setting :slight_smile:

The one below that “Smartscreen for Microsoft Edge” I have left “on”. Edit ~ Edge was still behaving slowly and freezing a bit making tab switching stall. I have now turned of the “Smartscreen for Microsoft Edge” and though tab loading still spins on some tabs, the other tabs are active and ready :slight_smile:

What puzzles me is that this feature(?) did not intrude before so was likely an Edge update perhaps in W10 version 20H2

I will have to see how Edge behaves because it was getting a bit slow with some tabbed sites, again something I had not seen before!

PS having said that about W10 20H2 , there is another 20H2 update waiting to be installed:-
December 8, 2020—KB4592438 (OS Builds 19041.685 and 19042.685) (microsoft.com)

PPS I have just tried the download again and no warning against it :slight_smile:

1 Like

Windows 10 Build 2004 (19041.662)

Windows Security
Antimalware Client Version: 4.18.2011.6
Engine Version: 1.1.17700.4
Antivirus Version: 1.329.89.0
Antispyware Version: 1.329.89.0

Default setting, all notifications are enabled
Downloaded in New Edge Browser by clicking Download and Update

One thing I may have done differently than (some) I saved the download before running.

Closed PLE and ran .exe by double click

No smart screen warning, nothing different that any other update. All Reputation Based Protection options are enabled. Took under 2 minutes. Might be something in 20H2 as others mentioned.

Ran the update a day later, no problem. Time to remove the tinfoil hat.

I thought this had solved the issue for me, but it hasn’t. It looks like SmartScreen has to be disabled quite thoroughly to stop the multiple attempts to block DxO downloads. :unamused: Now I wonder if it’s worth turning protection off just for a smooth download.

No, that doesn’t seem to be the case. It’s pretty clear from the messages that pop up that this is a reputation heuristic used by Windows Defender and SmartScreen: if an app and its source don’t seem to be popular enough to establish them as trusted, then a download and subsequent install are blocked. Over and over again - twice at the end of a download (if using Edge, as I do) and once more when trying to run it. Microsoft’s security software doesn’t learn from the user (even one with Administrator rights) and there’s no way to teach it.

This isn’t really a new issue, it’s just cropped up now with DxO. MS is (still) using a recency/reputation-based system but they’ve likely recently tightened the screws to cope with increased security threats. It should recognize the DxO PL install in a few days. In the meantime, just ‘install anyway’ as I did earlier today.