Undesirable behaviour: PL4 trapping/blocking Function-keys

I use another application in tandem with PhotoLab; I invoke it (bringing it into focus) with a configurable “Hot key” … eg. F8 or Alt+F9, etc.

This worked fine until PL v4 - even when using a Hot-key that operates as a Shortcut in PL, such as F9.

With PL4, however, this no longer works; PL4 is trapping and blocking such keystrokes even when they are NOT valid PL Shortcuts; such as F6, F7, F8 … such that my tandem app is now inoperable.

Can this undesirable behaviour be corrected, please ?

John M

I hope that is the consequence of them preparing for proper keyboard shortcut support, perhaps as soon as 4.1.

@John-M, I have created nearly all my shortcuts for programs (under Windows, right?) with CTRL-ALT- or a combination with SHIFT.
If the programs are already started and minimized to the taskbar I recall them with WIN-, for example WIN-3.
Both works perfect here. PL4 doesn’t block that.

(Yes, Win 10).

By way of explanation: The “tandem app” I’m referring to is actually Irfan, which I use to grab screen-shots - often to illustrate a post to this forum !

I usually use a “qualifier” (such as Alt or Ctrl) too, Ralf … However, in cases where I’m trying to capture the options in a PL menu list, I cannot use, say, Alt+F8 because “Alt” causes the PL menu to close … so, prior to PL v4 I was able to simply use F8, which worked fine.

Unfortunately, PL4 is now trapping ALL keystrokes upfront - and “swallowing” any that it does not need for itself.


Hi Svetlana/@sgospodarenko

Is there any chance to have this looked at ? Or, are we stuck with this new behaviour ?


Good morning, John,

Let me ask @alex to have a look at it.

Svetlana G.

1 Like

Hello @John-M,

Do you confirm that your shortcut works with DxO PhotoLab 3.x even today?


Hi Alex. Yes - this screenshot was taken from PLv3 using hot-key = F9 … but this does not work with PLv4 … Instead, PLv4 “swallows” this single-key hot-key, and does not pass it on.


Note: I normally use an additional “qualifier” - such as Alt+F9 … but when taking a screenshot of menu options I need to drop the qualifier because it causes the menu to close (before the screenshot can be taken). This was all working fine with PLv3 … but now, not with PLv4.

John M

@John-M, I try to follow you.
You told me, you use IrfanView. I do the same.
I start IrfanView with SHIFT-ALT-I, press “C” for screenshot. IrfanView tells me to use CTRL-F11 for copying the actual screenshot into the clipboard (or save it as file - depending on your settings). That works great here. I have never tried to do something in combination with ALT or a single F-key. This screenshot here is done with IrfanView this way. You can see the opened menu and the mouse pointer.

1 Like

Thanks, Ralf - That’s a useful observation.

Alex/@alex: Thanks for your follow-up - but, you can ignore my issue.

Whilst it’s true that something has changed between PLv3 and PLv4 - in that PLv4 now blocks certain key combinations that PLv3 did not - this is no longer a problem for me, as Ralf points out that Ctrl-key works fine as a hot-key qualifier when using Irfan to capture menu options.

John M

1 Like