Unable to Upgrade v 7 to the Latest Version

MacOS Sonoma.
Updating through the app fails with an error as does downloading the full version from my account page. Tried yesterday and today with no luck. What’'s going on?

A friend with a Windows 10 computer was able to update, but PhotoLab then crashes every time she starts the program, even after reinstalling it. She’s back to 7.6. Apparently there are a number of problems with this version at once.

no problem for me
Apple M1
Sonoma 14.5

No problem here either with macOS Sonoma (current) on Intel iMac 2019.
I’ve been running every build during the last months. They all worked as expected.
(Note that I’m not activating VP and FP in PL during tests)

Still no luck for me today. Attempting an update via the app results in an error and when I try to download from my account page I end up with a connection to the server timeout message after a few seconds.

M1
macOS 14.5
Screenshot 2024-05-31 at 10.33.18 AM

Since it seemed to be a network issue I decided to try and update from my other/guest wifi network. And what do you know, it worked. I don’t understand what the issue could be with my main network. I just updated Affinity Photo and the macOS using the same network and had no issues. Strange.