Unable to print with Photolab 6.2.0 build 41 on Mac

Unable to print with Photolab 6.2.0 build 41 on Mac. (Rebooted Mac and printer)
MacBook Pro Apple M1 Pro (32GB)
Printer Epson SC-P600
Screenshot 2023-01-14 at 16.51.22

All other applications print fine.
Any ideas much appreciated.

Same problem. Unable to print from PhotoLab 6.2 build 103. Windows 10. HP Z9+ printer. Can print fine from Photoshop, MS Paint, MS Photoeditor, and HP Click.

Note that I do see the job post in print manager. It spools, then says printing, and the job disappears from the print manager queue as normal. However, it never prints. AND it never previews, even though I’ve selected preview in the print settings. Preview works fine with Photoshop and every other package I’ve tried.

Hi SteveS, and welcome here.

From what I know the preview is part of the driver modul, which means, that the print job for some reason doesn’t reach that far … after leaving the print manager. Guess, that in MacOS it’s similar.

As I hardly use PL for printing, I just checked … the print went through.

Since years I’ve been on Epson printers now (office & FineArt stuff).
Also used Canon and HP printers at the office / at home.

Dear Steve,

maybe a look in tne eventviews (eventvwr) could lead yo to the problem.
Open it

try your print from DPL and check if there are entries in Eventview.

Little chance but …

I think if any other applications print with the printer the problem is by DXO, an you will have to create a support ticket.

I remember that there was some posts with a diagnostc tool by DXO, but don’t have a link

best regards


Could you send a request for assistance using the below link and explaining all the details


I hardly ever print from DxO, but I just tried a simple jpg. Running the same DxO PL6.2b41 on a Mac, Ventura 13.1, and printing on a simple Canon MG5350.
The print went through quite well. No issues, so I cannot confirm topic starter’s problem.