Unable to launch DXO since latest update

Hello. I have been using DXO Photolab 6.0 on my system on a trial basic for about two weeks and it’s done quite well. Then, this morning I received a pop-up saying a newer version (6.6) is available. So I went through the update process which went smoothly. But now when I try to launch DXO, I get the following message: “DXO Photolab 6.6 could not be started. Please try to free up disk space or memory by closing some other applications.” I have repeated the update to make sure everything was installed properly. Still, no go.

The thing is, I have plenty of diskspace on my system drive (over 300 GB free) and memory as well (16 GB). And, as I said, I had no problems with the previous version.

What can I do?

Hello jomun

We are aware of an issue affecting a small number of clients and are investigating to provide a fix very soon.
Please contact our support team or further assistance.


I’ve got the same issue
I’ve put in a tech support request, hopefully they’ll come up with a solution soon.

In case it helps, just to let you know the problem isn’t affecting everyone. I’m running Windows 10 Home 22H2 and after installing the PL6.6.0 update yesterday it launches fine without any error message.

Thank you, Barbara! Thanks for the link. I was actually hoping to do just that–roll back–but couldn’t find a source for the previous version. Do I uninstall v6.6 before installing v6.5?

Also on my system Windows 10x64 Pro 22H2 no problem (like @SAFC01).

Same configuration here: Win 10 Pro 64-bit, Windows version 22H2. But problems.

I’m experiencing the same problem. I filed a report yesterday but have received no response from DXO. Didn’t they check this update before issuing it to the public?

As barbara mentioned before
We are aware of an issue affecting a small number of clients and are investigating to provide a fix very soon.

Hi Barbara. I did in fact contact your Technical team. They responded just a short while ago with a link to the supposedly fixed version of 6.6. I followed their instructions, downloaded the installer from the provided link and then chose the “REPAIR” option on the installer (as there was still the earlier install on my system). It did not work. I received the same error message about a lack of sufficient memory and or drive space. I did, however, successfully install the earlier version (v6.5.0 Build 171). It worked but in the process I lost access to my original database, as it had been updated during the 6.6 install, and was no more compatible with v6.5. I lost a great deal of edits in the process. :frowning:

Same problem, after updating to PhotoLab 6.6 it won’t start.
Windows 11 Pro (21H2, OS build 220001936) RAM:12GB

Tried to Repair PL, which produced below error:

Then removed PL, restarted PC and reinstalled PL.
Unfortunately with same result.

A new Update PhotoLab arrived today.

1 Like

Great, that worked. Thanks for the quick turnaround to fix the issue.

That worked!