Unable to install PL 5 Trial

I downloaded the trial of PL 5 and started it up: it failed to load my PL4 database (after showing a progress bar in the splash screen for several seconds).

TL:DR: After many attempts and attempted work-arounds I have still not succeeded in getting PL5 to load my catalog database either from wherever the ‘live’ database is stored nor from my PL4 backups.

I do not use keywords, much, nor do I have more than the usual metadata (EXIF mostly) in my database.

These are the error messages I got when trying to load the database:

These are the steps I have taken:

  1. I quit PL5.

  2. I downloaded today’s update for PL4 (4.3.3 build 66)

  3. I reopened PL4 and backed up my database again and then closed PL4 and re-opened and restored the latest backup in PL4 to be sure there was no error in the backup. It looked fine.

  4. I then un-installed and re-installed the trial copy of PL5. But I had exactly the same problem! It could not read the database and gave me an empty Library screen.

Needless to say: I’m very disappointed. I’m also puzzled. This is just the sort of thing that I would have expected DXO to iron-out in beta-testing. I know user-environments differ a lot. But I have no problems running PL4 nor ever have had. So whatever it is, it seems to be specific to PL5.

The uninformative nature of the error messages is also unhelpful.

Hi Peter - Is there any chance you had PLv4 open at the same time ? - In which case, that could be a database lock message (?)

In which case, the easiest solution might be to delete the PLv5 database and allow it to start from scratch (reading your sidecar/.dop files … assuming you create them).

John M

Hi John,

It occurred to me, too, that it might be a D/B lock. So I was careful (on the third and fourth attempt) to make sure PL4 was closed. I did not inspect any files since I don’t know precisely where the D/B is (only the D/B backups).

I do create .DOP files in my folder-tree that sit alongside my images.

But I have a folder tree with about 120k images that I read into the PL4 database when I created it. I tried “indexing” one of the folders in PL5, but it took a while. I think that – eventually – might be my only resort, but it will take hours (essentially to rebuild my whole database). So I’m reluctant to do that.

I’ve had to rebuild my ‘Workspace’ too (although that took only 10mins).

Thanks for the suggestions.

I’ve had no trouble installing or running the trial, but I do have a rather catastrophic issue with it. I can open any folder and see the thumbnails but as soon as I open an image to edit there is no image shown and all of the tools are disabled.

I’ve even tried opening images from DxO-supplied sample image folders, and have tried Adobe-converted and camera-native DNGs and JPEGs of my own. I have stopped and started both PL5 and my Mac (M1) to no avail.

I have a support ticket open but while I wait I wondered if anyone has any ideas?

Peter - You’ll find a reference to its location in your Preferences …

Like this: image

Note: Unless you depend upon the database for keyword searching, etc - you can rebuild it stage-by-stage (as you “introduce” PL to each of your folders) … there’s no need to do it all at once.


Actually scratch that. After writing out what steps I had taken I realised I had not tried an uninstall/reinstall which I now have and this seems to have fixed it!

1 Like

Hi Peter,

This is of course not normal, so could you please contact us through our Support page, so we can investigate the issue more thoroughly with you? When sending the ticket, please add the reference to the forum post here, and then you can send me a private message to give me the ticket number so I can get it directly.


The DPL 5 database can be restored from e.g. a DPL 4 database backup. This worked in several tests, but not in all.

I found that it helps to open and quit a newly installed/updated version of DPL several times before doing serious things.

Thank you John. There is no such dialog/information in the Mac version preferences. No doubt I could find the file if I needed to (by digging). But I doubt that will help if PL5 cannot read the backup D/B.

You are correct, I think, that I could rebuild the database by reading-in the files in my collection one-folder-at-a-time. I may end up doing that. But first, I’m going to spend a bit of time with PL5 to find out whether I want to upgrade. :sunglasses:


1 Like

Thank you for this follow-up @kettch. I will do so in the next 24 hrs. I appreciate the offer. Regards, Peter

1 Like

Um… Here’s a surprise. I have had no problem, today, installing PL5 on my MacBook Air M1. I use this installation (I also have PL4 installed there) just for quick reviews away from my desktop. There’s a small directory of maybe 300 images that are in a PL4 database. PL5 seems to have opened the database on installation without any trouble.

Obviously this is good. But I’m a bit more worried now about what’s going on on my Desktop mac (iMac 2019, i9, GPU etc).