Unable to delete Silver Efex Control point (latest version) by selecting and pressing Del key on Mac

When a control point is selected it should not require having to go to the sidebar to delete it. Worked on Mac before. No more with v 4. The fixation on the sidebar being the location to do everything makes the product frustrating to use.

I must confess, in a world where everyone has their controls in the sidebar, where you have to focus on two places to make an adjustment (the image, and the slider), the adjustments at the control point were still, IMO, genius and could be quickly and easily manipulated. It was an almost darkroom-like processing experience in a digital realm. They were the one thing that made me return to Nik plugins exclusively after several years of using the others. I realize the argument is that in order to develop Nik plugins further the control of the points needed to be moved to the sidebar. Maybe the Nik control point design was already far ahead of what everyone else is doing and more focus should have been given to refining what they already had, not conforming to what the rest of the world is doing. Now Nik plugins have joined the world of sidebar sliders where there are already a lot of very strong and well-established competing products and, frankly, that makes me a bit nervous about the future of Nik plugins. I just hope PhotoLab doesn’t get rid of their control points or, though I’d rather not, I’ll be moving to On1.

Choose / mark the controlpoint you want to get rid of and hit delete
(works with old and new Nik modules / Windows).

Doesn’t work with Mac anymore. Worked in 3. It feels like DxO really screwed the pooch with this upgrade.

I use the Mac version and you are absolutely right. The only way to delete the control point is to click on the trash can. I voted, please click and vote too c.gephart.


1 Like

Thanks for the reminder!

1 Like