Trouble with corrupted images

Hi, I am having problems with corrupted images. When I make an adjustments in HDR Efex Pro Plug-in and then click the OK button to send it back into Photoshop the image appears corrupted with several squares appearing in the image. I have tried everything to sort it out. DXO can’t sort it either. I have the latest Mac Catalina version 10.15.14 and Photoshop plus the Nic collection as a plug-in. I use an iMac and an Mac Book Pro and have them same problem on both. I also have a couple of friends that have the same issue.

Is any one else having the same problem and can any one help.

Kind Regards
M White

Welcome Maggie

When you say your friends have the same problem - is that when using your photos or is it when they use their own photos?
Which versions of Photoshop and HDR Efex are you using?

When using their own photos.

I am using Photoshop Latest version 21.1.1.Subscription.
EfexPro Latested Version Part of Nik Collection 2 by DxO


Here is a copy of a corrupted image

1 Like

I’m having the same problem as of about 1 month ago
Sample attached

1 Like

As you can see I have been having the same problem for sometime and I know several others who have the problem too. I have contacted Dxo who have been less than helpful. They have suggested a number of things but nothing has worked including uninstalling and then reinstalling. They said they haven’t come across this issue before! I have also installed the old 2018 version to see if that works but unfortunately it still have the same problem.

I would be interested to know what system you use. I use the Mac Catalena on a Macbook Pro and an iMac. Both less than a year old. The problem appears on both. Have you contacted Dxo support if so I would be interested to know what they say now that the problem has been reported by someone else. If not perhaps you could email them too.

Kind Regards
M White

1 Like

Actually I joined the forum when I saw there was no further response from your posting, so thought I would add that “others” are having this issue too.
I am using on iMac with Mojave, latest PS, single exposure tone mapping.
Like you, I’ve tried multiple things to see if I could make the problem disappear.
One interesting thing is that it occurs on RAW images, doesn’t matter if they are Canon CR3 or Pana RW2. Also on JPEGS via photoshop (not that I would usually use HDR on JPG, but just to check), but NOT on jpegs from say a screenshot.

H Pete 1,

I know of at least three other people who have the same problem but may be with the old version. I have paid for mine so am a bit miffed that the thing I paid for is not working properly. I have been back to Support again but no response to date. Have you had any communication with them?

I use both RAW and JPG and have the same problem with both. I use lightroom first and touch up in Photoshop sometimes using the Nik Collection as a Plugin when using Layers. I do it this way as I like to use the Opacity slider. I

Kind Regards
Maggie White

1 Like

Unfortunately I see there is still no response/solution from DxO
I’m personally giving up and will use other solutions.

1 Like

Have you been able to sort the problem out yet. I have sent several emails to NIK suport but they don’t reply. Very poor support.

Maggie White

I’m not a Mac or PhotoShop user, but am a trained troubleshooter - so I wonder what your collective experiences of this problem have in common. Are you all using layers in PhotoShop? Is anyone having this problem not using PhotoShop or layers? Does the problem only occur with the Nik plugins? If so, is it possible to do the work in stages (discrete steps) without using Nik as a plugin and see if the problem still occurs somewhere along the way?

There are reports many years old of a problem like this happening without DxO software, on Macs running Adobe software. No solution was found, but Adobe was blamed after ruling out other possible causes. That doesn’t mean that this particular issue isn’t due to a problem with the Nik Collection, but it does suggest that something might be going wrong outside of DxO’s control.

Yes I am using an Mac and a macbook pro. Both have the same problem with the Nik plugin since I purchased the 2 version. I have never had this problem before on older versions. I have tried it with and without layers but still get the same problem. It happens mostly with the EfexPro. Yes it might be outside DxO’s control but their support has not been good. They asked me to download a diagnostic application and send them the results which I did over a month ago and have heard nothing. I have sent them several reminders. As you will see from above I am not the only one to have this problem.

My experience with the Nik Collection team is the same. Since DxO won’t update you on their progress and plans, it seems necessary to break the workflow up into steps to see where the problem is occurring. Is it possible for you to isolate Nik and the Adobe software? For example, if you’re sending an image to Color Efex Pro, try exporting to a TIFF file instead and then bring up the TIFF file in Color Efex Pro. Then in Color Efex Pro save the work to the same TIFF or to a new TIFF and examine that file to see if it’s corrupted. Bring the saved image back up in Adobe: is it displaying correctly? Does exporting to different image formats and file formats (TIFF with compression, TIFF without compression, 16-bit, 8-bit, etc.) make a difference?

I expect that both DxO and Adobe software will work with 16-bit TIFFs, with or without LZW compression and any other options you might want to choose. If there’s something incompatible with the way the two handle compression or the TIFF container itself, I hope it will show up in these tests. If the problem is more internal to how the two software packages communicate with each other, or with memory or cache or some such component of the system, it probably won’t show up in these tests. (I can only offer theories because I don’t know how all the components of the system interact.)

I am also experiencing this issue. The problem appears to be a reintroduced issue from several years ago. Sorry but that’s all I remember. It is extremely frustrating and des need fixing urgently

1 Like

Oh and Catalina (10.15.6)

Using DxO / Nik HDR with PS 20.0.10 I do NOT see the problem.

Hello all… I have been searching high and low for an answer to this. I too am having the same issue when using PS 21.2.1 (that is one of the reasons I ALSO have PS 2019 installed). The “Squares” problem.

This is with the latest / greatest paid version of DxO / Nic x64 (3.0.7).

My system:

iMac (Retina 5K, 27-inch, 2019)
3.6 GHz 8-Core Intel Core i9
72 GB 2667 MHz DDR4
Radeon Pro 580X 8 GB

Seems like my system would be robust enough to NOT have this issue?

Has no one tried my suggested tests? Problems can’t be fixed if they can’t first be analyzed.

1 Like

Having had the same problem on my iMac, the only way DxO could solve the problem was the following. It seems to work but takes longer.

" Open your image in Photoshop. >Make a duplicate Layer. >Go to your plug-in filter and select the the NIK filter you want. (for me it is the HDR EFex Pro 2 that I have the “Squares” problem with).
When the NIK Window opens go to he bottom left hand corner and select “Settings”. Go to “GPU” then UNTICK the box that says "Use GPU for image processing.

I have use this fix which so far has solved the problem although why it happens is a mystery. Give it a try and let me know how you get on.

Maggie White

1 Like

I think you have already suggested this but my first test would be to just open a file in HDR Efex (or other Nik plugin) directly and see if the problem occurs, this may isolate if it is a HDR Efex issue or some sort of interaction with other editors issue.

I have not seen this issue before. I don’t use Photoshop but do use HDR Efex with other editors as a plugin. When using as a plugin I tent to output as a 16 bit Tiff uncompressed with AdobeRGB colour space.