Trouble activating after cloning hard drive

Has anyone had a problem with DXO software where the software thinks you were running a demo and need to activate after cloning your operating system hard drive when nothing else changes other than a new drive?

I am struggling with this, I cloned my OS drive, when I try to run PureRAW 4 it asks to activate but refuses due to too many activations. I reached to DXO support and all I am getting is questions back and forth, I submitted the request last week, but apparently it was not received, I resent it again and all I am getting is someone trying to find the original submission, but not helping after a resubmission of a detail explanation of the issue.

I will greatly appreciate your feedback.


It sounds as if you have done what you can do and now it’s DxO support which need to do their job.
Simply wait a day or so and they will reset your registrations.

It sounds like the hardware changes you have made have “tricked” your DxO software into thinking you are trying to run PureRAW on a new/different PC - and now you have exceeded the number of allowed activations.

As @Required suggests; you will need to wait for DxO Support to sort this out for you.

1 Like

Thank you,

Interestingly, DXO software is the only one that thinks I have new hardware; Adobe, ON1, etc., are happy.

@MikePhotog I started a response where you first posted which goes something like this but please note that I am a DxPL user not a PureRaw user and there may be additional changes with PR 4 !?

Firstly did you do a “full” copy, i.e. preserving the disk id. number?

I haven’t retested this scenario recently (but did after I started typing the response) but some time ago I was testing various releases in an attempt to isolate a possible change in colour representation.

To do this I cloned a drive with a licensed copy of DxPL(Win) and then retrofitted an earlier patch release (by completely uninstalling and the installing release X) which preserved the original activation…

I then cloned that newly created SSD and upgraded to a new release X+1 and then repeated so I had X+2., i.e. 3 SATA SSD boot drives.

I have SATA switches on all three of my machines so all copies of of the clone were attached to the SATA (power) switch on the test machine and that allowed me to switch between boot drives easily, rebooting before each test but storing the snapshots on my NAS drive.

The swapping and retesting worked just fine so I re-cloned just a few hours ago and swapped the boot drives and PL4, PL5, etc. worked fine.

So with DxPL the cloning works but my clones preserve the disk serial number/disk id i.e.

It is possible that the technique might work with PureRaw 4 but it is also possible that DxO might (have) come up with a even more sophisticated check (although how you can beat a complete clone of the disk including the disk id. running on the same machine as the original I am not sure).

PS:- Beware issues after the clone is made because Windows will not accept two disks on one machine with the same disk id.!

1 Like

Hi Bryan, thank you for the detailed response. I use Macrium Reflex. I cloned the original drive and removed the old one. I am not sure if Macrium keeps the same drive ID, but I would assume it does. I also assume that Windows is telling PureRAW that a hardware change happened and may trigger the need to activate it.

I am also very aware of the need for software developers to protect themselves against piracy, but DXO’s support is dismal. Right now, this person, Riley, keeps sending e-mails back and forth with questions; in the last response, he tells me that I have to remove the software from my “old” computer before I can activate it on the new one. Either he or she is not reading my messages or is trying to give me a hard time. In the meantime, I cannot use the software.

Thanks again for your feedback.

@MikePhotog I am not sure that Macrium Reflect does preserve the Disk GUID and my tests only included DxPL and it is always possible that DxO may have implemented a fiendish new protection system in the latest PureRaw release (or not)!

What I am sure about is that the current activation/de-activation system is useless and, when coupled with DxO Support personnel, it appears to be worse than useless.

Arguably Riley is correct about removing the software from the “old” computer since that is “holding” one of the activations you need. A simple scheme of activating/de-activating on the activation logging system appears to be missing or DxO are concerned about users keeping old activated versions around?

Given what I believe happened in the past during my tests with multiple versions, completely removing the software from the system did not appear to invalidate the activation.

So when I installed the software afresh I do not believe that I had to re-activate it, i.e. there was (still) a valid activation “hiding” somewhere!??

Also I have read posts about the need for DxO Support to gain access to your machine to completely eradicate the activation which just sounds rather crude!

To determine the Disk GUID (DeviceID)use Powershell and enter

“GWMI -namespace root\cimv2 -class win32_volume | FL -property DriveLetter, DeviceID” when you should get something like this

My Boot drive is C:\ but some programs are also installed on "E:.

If you are able to attach the old drive, e.g. via a USB 3 connector then you should also get the ‘DeviceID’ for the original disk and can check they are the same, except the OS won’t let you attach two drives with the same GUID at the same time - oops!?

So if you can have both drives active at the same time then their GUIDs are not the same!!

You could then try setting the GUID for the new drive to that of the old drive once you have copied the number and taken the old drive offline!?

Although I have played with the DxPL database to “hack” the UUIDs in the database that correspond to DeviceIDs I have avoided actually changing the DeviceID of any disks!

I have tried it but it consistently causes PL to crash. It’s completely unusable on my computer.

@peterw What causes PL to crash?

  1. Making a clone while preserving the DeviceID or
  2. Making a clone and not preserving the DeviceID or
  3. “Hacking” the DeviceID to make it the same as the original or
  4. Something else!

If PL is crashing is it dumping, giving errors messages or what?

Plus what OS are you running on and what version of DxPL is causing issues?

PS:- and why did you need to take whatever action you took?

PS additional:- and what state was PL in before you took whatever action you took?