The bug is back

PhotoLab 5, MacBook Pro running Catalina.

Back in the Optics Pro days I filed a bug report saying that OP failed to show thumbnails from new files created in the folder being edited. That is, if I send an edited raw image, as a TIF, to Photoshop, edited it there and then saved it back under a new name, the new file did not show up in the filmstrip unless I changed folders and then changed back. And sometimes not even then. Dxo finally fixed that, but it has showed up again from time to time with new releases, and it is back in PhotoLab 5.

I noticed it when I did processing, using the Nik collection, of a series of shots to make up an HDR. PL5 processes them to tiff, starts the HDR Nik app and then when I save that back to the folder I don’t see either the initially created tiffs or the final HDR tiff unless I change folders and then change back. This makes it impossible for me to further edit the created HDR without changing folders. I did not see this behavior in PL4. Just to be clear, the software is set to display both raws and RGB files.

It puzzles me why this keeps showing up in some of the new updates, including both minor and major updates. Has anyone else seen this in PL5?

Just wondering if this matters: are you writing to a local drive, NAS, or something else?

The images are on an external ssd, but that is how I have been editing them since OP 5 so I don’t think it has any bearing.

I don’t think it’s related but just in case I will mention it. When I installed the PL5 trial, it would show thumbnails for any folder I pointed it at, but opening any photo resulted in an empty Customise view with a default zoom of 0%. The cure was uninstall and reinstall.

It is worth a try, so I will see if that helps.

What has been annoying me the most is that this specific problem has shown up in both OP and PL, on and off, for the past 7 or 8 years. When I first saw this with OP Dxo did not own Nik and so it was not integrated in the software and I saw this when I sent an image to Photoshop and returned it for further processing. Dxo’s initial response was that I should not do that. Oh, I asked, then why do you give me an option to export to another application. Finally Dxo said that yes, it was a problem and they would fix it.

PL now has a lot more tools and I don’t usually have to send anything to PS, but I now have the Nik collection and I do a fair number of of HDR shots so I see with with every HDR sequence I process in the PL5 trial and it makes it a pain to further edit the saved HDR image because I have to either change folders or exit PL5 and restart it to force PL5 to re-read the folder.

It didn’t help. I have uninstalled and reinstalled the app and the problem still remains. Still, it was worth trying, so thanks for the suggestion.

1 Like

I can confirm a similar bug in PL5 for Windows. When I export a RAW image to Nik, a TIFF file is created and visible in the image browser (filmstrip). However, when changes are applied/saved in the Nik Collection app, they aren’t immediately visible in the PL5 thumbnail. I have to click on the thumbnail to bring up the image in the image viewer before the thumbnail shows the edits from Nik.


Every once in a once I had that problem in PL 4 for Windows with Nik 3, but it was very hit and miss. However, I have not seen it occur at all in PL5.


I would think that the root cause of both problems would be similar - a failure to read and propagate changes to the display software. For you reading the updated dop files and for me re-reading the folder and propagating that to the display software. But, of course, that is only a guess.

When this first showed up many years ago I did some research and found that the Windows version had a command to force a re-read of the folder while the Mac version did not have that command. I don’t know if such a pull down/keyboard command still exists for the Windows version but if it does it would be interesting to know if it forced a display update. There is still no such command for the Mac.

I have the same issue (new file doesn’t show, have to move out and back into a folder and it’s a intermittent thing). It is not new, it’s been there ever since I’ve been using DXOPL (v3 on). With every release I hope it will fix itself. Been the same on two different desktops and my trusty old laptop.

I wonder if this is a general interface to windows file managment isue as I have been reporting a problem with saving to disk.

For what it is worth I have filed a support ticket with Dxo about this. Again.

But that is for the Mac version.

Not likely to be the same then

That is interesting. And, out of curiosity, based on your post, I created a new HDR and when the processing was complete the tiffs were missing, as usual with this release.

However I tried clicking on each raw image and, when I did, the associated tiff showed up in the filmstrip. Every click on a raw image used in the HDR processing brought up the missing tiff. However the final HDR tiff did not show up because there was nothing to click on to bring it up. Still, that is interesting and I suppose I should update the ticket to mention it.

Thanks for the post.

1 Like

I do get a similar problem where I open a folder and the thumbnail renders are inconsistent. Namely, each thumbnail ends up in one of three states:

  • Properly rendered
  • With an initial thumbnail and the circular arrow still overlaid
  • Blank with the circular arrow overlaid

So it seems like the updating code has holes where it thinks everything is up to date when it is not.