Sudden error message when trying to open up Nik Software from DXO

Quite suddenly when trying to open up Nik Software from DXO 3 I’m getting this message:
The given path exists but is not writeable. Precessing cannot continue.

This only happens when opening a file directly from sd card in a reader, does not happen when opening a file already on saved on disk.
I’m on Mac OS. Thanks for looking.

Did you check the drive letter?


Is it possible that the SD card has write-protection enabled ?

John M

… I often get read only on a sd card because the switch is flipped when the card is inserted or taken out of the reader.

Other than that, I’d not work from the card. Better copy the images to a decent internal or external drive before doing anything with the files. This reduces the risk of losing the files.

This appears to be a widely-reported problem with MacOS computers. Here’s one possible solution:

One user whose report I read solved it by formatting the card with FAT16 structure. Personally, I’d format the card in camera to avoid possible problems where reliability matters most. But it seems to me that if the problem is “random” then it’s the card reader not seeing the card’s physical state correctly - thus, the switch trick mentioned in the link above seems the likely fix to me.

I did try moving the switch as suggested but that didn’t work for me, I always format the card in the camera. Thanks for the link, makes interesting reading none the less.

Problem solved.
Turns out it was the card reader. When using that reader the “info” on the card showed “read only” and I noticed that when withdrawing the card without using the “eject” command the usual desktop warning message did not appear.
I checked through some of the possible solutions mentioned here and also some of the bizarre solutions on the web without success.
It was the lack of desktop warning that made me use a spare card reader and the problem in DXO simply wasn’t there, I was able to open the Nik plugin and “read only” permission on the card also went away.
Thanks to those who replied to my problem so swiftly.

1 Like