Strange artefacts using DeepPrime/DeepPrimeXD in PL6


I am trialing PL 6.0.2 new DPXD(DeepPrimeXD) as well as DP(DeepPrime), on a 14-inch MacBook Pro M1 (16GB, Ventura 13.0). What I see are aliasing type repeating patterns using both de-noise methods on final export to JPEG (100% quality). Also the colors are different between DP export vs DPXD. I thought perhaps it was a JPEG glitch but same result when exported to TIFF.

The photos are of the lunar eclipse on 8-Nov-2022, using a Sony 600mm lens with a Tx2 extender to give effective 1200mm.

The DPXD export, you can see the purple repeating patterns.

The DP export, repeating patterns are not as pronounced but colors is more green.

Another thing is that the DPXD preview can appear very glitchy as per below

Is this the correct place to post such issues, or is going to DXO support recommended ?

Hello and welcome,

That’s really whacky, I’ve never seen anything like that before and I have no idea(yet) what could be causing it. Could you upload the RAW file and it’s DOP file to a sharing service(such as Dropbox. p-Cloud, WeTransfer, etc.) and post a link to it here so that we can try to reproduce the issue?

All three issues have been reported before in these forums. The color difference is a bug on Mac that hopefully everyone is reporting to support and providing sample images for. The glitchy noise reduction loupe is seen sometimes on both Windows and Mac, but seems worse on Mac. The cause of the patterns is almost certainly distortion correction, but can be easily determined by testing various conditions:

  • Turn distortion correction on and off.
  • Turn vignetting correction on and off.
  • Turn ClearView Plus on and off.
  • Try it without DeepPRIME/XD and see if the pattern still exists.
  • Were you using a filter on the front of your lens? That could be the underlying cause of such a pattern (Newton’s rings) - but this pattern looks like a previously reported artifact of image processing to me:

(and elsewhere)

Will do but might need at least 24hrs as I’m on the road traveling.

Here is the link to the RAW and the two DOP’s:

If you want dxo to help you, you need to make a ticket. Maybe they read this here , maybe they don’t .

They are very busy and slow to respond to tickets though, it is what it is .

Hey Eg

I turned off distortion/vignetting/clearview corrections and the artefacts have disappeared on export with DeepPrimeXD! And it looks pretty good. Also I was not using a filter, just the Tx2 extender.

Here’s a question then regards distortion/vignetting, should one let the camera correct for distortion automatically, or do it post in software? Also if one lets the camera correct for distortion, and I also have correct for distortion turned on in DXO, will it be overcorrecting ?
I’m just getting started on all this really and it’s a little daunting all the settings.

Hey j, yes I have created a ticket and linked this thread. thanks

I am unable to reproduce your issue. Here is the exported file with DPXD applied. I also raised exposure by about 2 EV to check closely for the issue. It isn’t there. Hopefully DxO support can find what the issue is for you and correct it quickly. :grinning:

That’s pretty weird, as I can reproduce it every time. I’m not 100% sure I’ve sent the correct dop, but what I sent was the one immediately after I exported so should be the correct one. Also are you on a Mac with same hardware and OS as me ? Would you mind sending me your DOP just so I can try it on my end , ensuring lens corrections are turned on. I will also try using the latest version of PL5 which I purchased a few months ago as well. Thanks.

Okay, several questions to answer:

  • My PL6 ignored your DOP, so no I didn’t use it but I did try turning various adjustments(Clearview +, Distortion Correction, Vignetting Correction, Lens Sharpness, Chromatic Aberration Correction and Smart Lighting) on and off, all with no change in the export.
  • I am on Windows 10, not Mac.
  • The version that I posted had all lens corrections(including Lens Sharpness at my default setting).
  • Here is the DOP file:

_DSC2183.ARW.dop (9.2 KB)

I have exactly the same problem on a M1 MacBookPro running Mac Os Ventura!
In the advanced settings of PL6, modify “Apple Neural Engine” to “M1 GPU”.
The problem is gone but PL6 will become very slow at exporting.

To summarize

Hey Europat
Thanks for looking into this as well, if you have time do you think you could download and process the RAW image I have linked earlier in this thread to see if you can also produce the same artefacts I get ? Also please make sure lens correction is on as well.

So far my example seems to be the most extreme one I have seen, nothing subtle about it, and I have not yet received any feedback from DXO support. So if we could get two Mac users confirming same results, then I think it might be safe to say we have a reproducible bug. Thanks!

Dear rdy2snp,

I downgraded my MacBookPro M1 to Monterey and reinstalled PL6.

The problem has disappeared with both DeepPRIME & DeepPRIME XD using the Neural Engine acceleration.

Here is the jpeg export (DeepPRIME XD) of your RAW file (using your DOP & the correct camera/lens profile.

Hi Europat

Interesting, did you get a chance to test my RAW with Ventura ? So far I’m the only datapoint to confirm that I’m getting crazy artefacts with that particular image, would be nice for another datapoint ; )

I also tested with PL5 and can confirm the same artefacts remain while the default Neural engine is selected. So at this stage it looks like some sort of change, perhaps Neural Engine API between Ventura/Monterey is causing this issue. One would hope it’s a simple software fix at DXO end, and not a bug at Apple end.

Unfortunately DXO have not responded to me yet, from the long silence I’m guessing they are a pretty small outfit. Thanks to the folks on this forum though, quite an interesting introduction to DXO ; )

Hi rrblint

Sorry for the slow reply, but I just now tried your DOP after replying to Europa, and upon first export I did not get the artefacts, or if they were there were unnoticeable compared to my original post, which was interesting as you had the lens corrections on. As soon as I switched on smart lighting though, they came back!

Per the other replies from Europa and myself, it then seems like there might be some change with Apples Neural Engine between Monterey to Ventura that is affecting the export using both DeepPrime options when Smart lighting is turned on at least.

Dear rdy2snp,
As my system (Montery/PL6) works now fine, I will wait for DxO or Apple to fix that before reinstalling Ventura. Sorry, I didn’t process your RAW file with Ventura/PL6 but I encountered exactly the same bad results with my files.

I received an e-mail from DxO Support this morning:

Bonjour Monsieur B,
Nous avons sorti une nouvelle mise à jour intégrant un correctif,
c’est cela qui a réglé votre problème.
Nous vous remercions pour votre retour.
Nous considérons donc votre demande comme étant résolue et la clôturons.
Merci de ne pas répondre à ce message.


Cécile - DxO Labs Support Team

Hi Europat

I just received this response from DXO , sorry I’m not a French speaker but perhaps your message is the same as below.

“Thanks for contacting DxO. I’m sorry it has taken so long to reply.
In this case I’m afraid it’s a software error. The developers are already working on a solution for this which should be released via an update soon. I’ll let you know when more information is available.”