Stop DxO thumbnail preview

My CR3 raw files are shown with the DxO PL icon per default. How can set the thumbnail display to default to another program, preferably Adobe Photoshop?

What platform are you using, Windows or Mac?

1 Like

On a Mac, set the checkbox in this dialog window (invoke with command-j):

Thank you. I tried as you suggest, and set to “immer öffnen mit” Adobe Photoshop, restarted computer but the changes just won’t take effect. Every time I open the same folder the DXO PL logo is plastered over the RAW files, and double clicking them opens them up in DXO PL.

Thank you Mark, I am using Mac - see my answer below.

And moreover, when that checkbox is deselected that you suggest, the jpeg thumbnail preview is disabled as well, which is not ideal.

Sorry Chris but the reason I asked was because I know how to change it in Windows but not in Mac. Someone else will know how. Good luck.

macOS will only display thumbnail previews if the box is checked - and if the camera body is supported by macOS. Read this.

Thumbnails off

Thumbnails on

Note the difference in Checkbox “Symbolvorschau einblenden”.


If I understand well your question, when one CR3 file is selected in the Finder, use Cmd+I to get the info window and in this look at the “Open with” item where you should see DPL which can be replaced by the program you choose.