Sony ARW files ... a very basic question

I have just started a free trial of this software and find that it will not recognise Sony ARW files. I expect that I am making a beginner’s mistake, but I would be very grateful if someone would tell me how to fix this.

Thank you

The software recognizes Sony ARW files.
First, isn’t there an active filter ?
“Show RAW images”

Hello Matthew,
I have Sony for ages and never encountered a problem , all my ARW files are recognized. Which trial version do you use? Now Sony has or had a compressed Raw . I don’t use this and I don’t know if this is still the case. Maybe that could be the problem.

Hello @MLHB and welcome to the forum,

We support different Sony cameras with ARW format but you should check if yours is in the list:
DxO Optics Modules -> Download… :

If not, you can report a suggestion:


Svetlana G.

Dear Svetlana

My camera is supported by DxO - it is a Sony A7Riv, which is quite standard. However I am getting this error message: This image cannot be processed because of an unknown error. It may be corrupted or in an unsupported format.

The images are not corrupted and open properly in other apps and in Mac Finder.

I would be very grateful if you or someone in your team could help me with this, as this is exactly the app that I am looking for.

With thanks


Yes, Matthew, SonyA7R_IV is supported by PL3. So, could you, please, provide us with some of your RAW files for the investigation?

Please, upload them on under your name (instead of support ticket number) and let me know when ready.

Thank you,
Svetlana G.

Are you sure you are not using compressed RAW format? According to this list, only uncompressed files are supported.


list is wrong, on Sony A7R IV compressed and uncompressed files are supported.
We will correct the list soon.

As Svetlana said we need some RAW files to investigate because so far this is the first problem we have with Sony A7R IV.


OK. I just found a site with sample images to download and, as you say, those compressed files seem to open fine

You had the right reflex to look at the camera supported list, sorry for the mistake :sweat_smile:

No problem. Except for now I’ve seen what a Sony A7R IV can do, with its pixel-shift 240Mpx capability, I’m now wondering how long before Nikon catch up :crazy_face: :stuck_out_tongue_winking_eye:

But that’s the problem with having worked in large format film, which gives around 300Mpx.

Hi Svetlana and Marie - I’ve just uploaded an ARW file that will not load in my copy of DxO, but which opens in other photo apps.

Is it possible that something went wrong when I downloaded the trial version of the app? I have slow satellite internet and the download took about 2 hours.

Thank you for your help.


1 Like

Hello @MLHB,

thanks for image.

ARW file is a compressed RAW but as I said we support it.

I agree it doesn’t open in PhotoLab but it doesn’t open in Lightroom (or Adobe dng converter) either.
Your image has about same weight (59 111 KB) as our compressed RAW (60 599 KB) so it doesn’t seem a problem from upload but really with the image.
Here is what I have

What other program do you have ?
Can you confirm you can export an image from these other apps ?

Can you try with photos in uncompressed RAW fromat ? Maybe try to reset your camera.


Dear Marie

I’m not able to reply direct to your email, as it is a ‘no reply’ address.

Yes, that’s the picture I uploaded. It opens in Photos, Affinity Photo and FastRawViewer, as well as Mac Finder.

I am now uploading an uncompressed ARW file, which opens in Affinity Photo, Mac Finder and FastRawViewer. I haven’t tried it in Photos.


With thanks

Hello @MLHB,

OK you can open photos but can you export them with these apps ?


Not your A7, but my RX10M4 ARW’s process through PL3 and NiK with no problems.

With Apple Photos and Affinity Photos I can open ARW files, view them, edit them and export them - all working perfectly. I can view ARW files in Mac Finder and FastRawViewer, but they are simply browsers so they don’t have an export function, though in FastRawViewer I can pass ARW files direct to Affinity Photo for editing, exactly as intended. However, I cannot open ARW files in DxO.

Also, I notice that in folders and files that I have attempted to open in DxO there are now .dop files associated with each ARW file. The have the file extension .ARW.dop and are mostly 635 or 640 bytes in size. When I click on them they produce the same error message as when I try to open the ARW files.

Please confirm that it is safe for me to delete these .dop files, without harm to the underlying ARW images.

I would really like to buy DxO P3, as it seems to be exactly what I am looking for, but obviously I cannot do so until this problem is fixed.

Hoping that you can help.


PS if you would prefer our conversation to take place offline please email me from an address to which I can reply direct.

The DOP file is created by DPL and contains all the settings you could have made for the associated RAW file.
Therefore DPL is non-destructive for the RAW file.
You can delete the DOP files but you will lose the settings made for the associated file.

1 Like

The changes are stored both in a database and in a dop file. If you delete the dop file your edits are still in the database. It is your decision to use dop files or not. Just go to preferences and tick/untick.

Many people decide to use dop files because a database gets easily corrupted, so to have a dop file is a safer option, kind of a backup to the database. In case it gets corrupted you just delete the database and all your edits are still avaiable in the dop files

Almost all of my photos are raw ARW and I have never had any problems with PhotoLab, whether raw compressed or uncompressed. And this, with raw from A7RII, A7RIII and some from A7RIV.
Wouldn’t the raw be passed before PhotoLab by a software which would have modified the exif?