Some issues in PL 2.x (Windows 10x64)

Some issues in PhotoLab 2.x:

1.) I’m in the “Work Modus” (I hope this is the correct translation) and delete some images of a series of similar pictures. The film strip with the remaining image(s) now jumpes to the left border, so that I don’t see the last image I worked with. In PL 1.x the pictures stayed where they were, somewhere in the middle. That’s especially bad for me, if I want to renumber the pictures and don’t the see the last name anymore. I have to move the film strip back to the right first.

2.) I renumber and rename all my pictures before I export them (I would like a closed numbering without gaps and a brief description of the subject in the name). I can do this a couple of times, maybe 10 or 20 images, then the “edit modus” (F2) doesn’t work anymore. I have to go to the “Fotothek modus” and back or sometimes close and reopen the program before I can go on. This is very annoying.

3.) Sometimes when I want to go on editing images:
I open PL, change from the “Fotothek” to the “work modus” and click in the gray area right next to the arrow under the filmstrip to get to the wanted image. I can do this only one time. A second click does not work. I have to grap the arrow and move it.

Not an issue, but an often wanted and long awaited wish:

4.) Still no possibility to flip (reflect) images (right <=> left, up <=> down). Or I didn’t find it.

1 Like

If by flip you mean rotate, you can do that with a right click of the mouse and select rotation. or you can select rotation from the Image menu, or on a Windows 10 machine you can use the Ctrl-L or Ctrl-R. key strokes. If by flip you create a mirror image, then no, you can not do that in PhotoLab 2


1 Like

I know how rotate works and I mean a mirror image. That’s why I used the word “reflect” (with a little help of Google Translate). I would really like to have this gimmick.

Hello @Ralf_Brinkmann,

And this one is also strange because it works on my machine again (if I do understand you correctly):

So could you, please, provide me with your user.config (c:\Users\user_name\AppData\Local\DxO\DxO.PhotoLab.exe_StrongName_XXX\2.0.1.XXX) and the logs ?

  • Not yet done but in plans.

Svetlana G.

Hi Svetlana!

Thanks for your answer. How can I provide you or send to you these files? And which one are the log files? There is a “LogConfig.nlog” in “C:\Program Files\DxO\DxO PhotoLab 2”. Is this the right one? Or all the *.txt files in “C:\Users\Brinkmann\Documents\DxO PhotoLab 2 logs”?


You can attach them directly here and I need this log - C:\Users\Brinkmann\Documents\DxO PhotoLab 2 logs

Thank you,
Svetlana G.

Ok, I’ll try my best. :slight_smile:user.config (38,9 KB)
DxO PhotoLab 2 (382,5 KB)

And please, what can I do with nr. 2.)? I can not edit the filename any longer. That stops me in my workflow. It’s in a hurry.

We will check your logs first, maybe they can reveal the issue. I’ll keep you informed.

Svetlana G.

Sorry, I’m sitting here and don’t know what to do. I can not go on editing my 200+ photos from saturday. Is there any trick I can try out?

Actually yes,

You can try to do a clean up but to ensure you won’t loose any of your settings let’s do the following:

  1. Close PL.
  2. Rename the following folders (in order you can return to them):
    %LocalAppData%\DxO\ and %appdata%\DxO\DxO PhotoLab 2\Database
  3. Start a PL (it will be started with default settings).
  4. And check the behavior.

Svetlana G.

Okay, I’ll try this out later. I’m out of the house today. Thank you. I hope we can find the reason for this problem.

Hi Svetlana!

As expected it works. But that was also the case after installing PL 2.x for a few hundred pictures, before it stopped working. I did not test the delete-issue, but I can edit the filenames. That’s most important for me at the moment.

But this can only be a test and no solution for me, because then all installed presets and other settings (like export formats) of PL 1.x and 2.x are gone.

In PL 1.x I never had a problem like this.

I hope you find the reason for it by exploring my logfiles very fast.

I have just tried to go on with the last version of PL 1.x (1.2.2 Build 3239).

It would work, I could edit and rename my images, but unfortunately this version does not read the content of the newer *.dop files from PL 2.x. So I would have to do all the work again. :frowning:

This is no fun.

Yes, sure it’s just a work around while the issue is investigated.

Ralf, but why don’t you do that with PL2 as you said it works now? Btw, you can import all the presets you needed from folder you renamed.

Svetlana G.

Svetlana, I think you misunderstood me.

With PL 1.x I can work without changing anything. Just start it and work, as I did all the time before PL 2 was published. But PL 1 can’t read the *.dop files from v.2.x, so I would have to do all the files from the actual project again.

If I rename the folders you told me, then all presets, settings and so on from v.1 and v.2 are gone.

But later I will go on testing. Maybe I take some screenshots of my settings. And I’ll try to copy the preset files from the old presets folder to the new one.

1 Like

I did understand that you use PL1 with no issue but it’s expected that the newer dop files can’t be read by a previous version (upgrade is possible, downgrade is not). I was puzzled why you do not use PL2 as you said it’s ok if you do a work around (yes, missing presets and modules can be copied from the old folders to the new ones).

Svetlana G.

That’s what I have done now. Renaming the folders you told me, starting PL 2.x once. Closing it, copying the missing preset files to the corresponding folder, starting PL again, installing the required camera modules and then start editing. Now let’s see how long. I think my program settings are the standard settings. I only have to add some export formats.

But I still hope you find a reason for my problems in the log files.

Btw: It’s again the same effect when I delete some images. The remaining pictures jump to the left border of the filmstrip.

Edit: I could edit 19 more pictures. When I started with the 20th, PL stopped again and did not let me rename the file. The size of the PL2 database file is just 1487 KB now.

There might(?) be a clue there, Ralf.
Perhaps, with all the renaming you’re doing, the database is becoming “confused”.

If you don’t care about the database (as I don’t) and you’re happy to rely only on the sidecar/.dop files (as I am) then you could try deleting the database, on some “regular” basis (as I do).

The PhotoLab v2 database is located here (in a Windows environment): "%UserProfile%\AppData\Roaming\DxO\DxO PhotoLab 2\Database\PhotoLab*.*"

Note: This suggestion is proposed only as a workaround … whilst Svetlana deals with the wider issue.

Regards, John

Hi John!
Thank you for your help. But I think, this isn’t the problem. This time (with only a few edited pictures) the database file was very small. With the old DxO Optics Pro and with DxO PL 1.x I have edited thousands of images and had never a behaviour like this. It’s always the same. I can edit the RAW files with all the tools of PL, but I can only change some filenames, then it stops. I have to leave the program and rename the files in Windows, then go back and do all the image changes again. When I open PL and change from the “PhotoLibrary” to “Customize” and then click into the grey area right next to the arrow under the filmstrip I can do this only one time. A second click doesn’t have any effect. Clicking left beside the arrow always works. And when I delete a group of marked images in the filmstrip the next image jumps to the left border. One “cursor left” brings it back to the middle of the visible row.

I have a quite normal Intel i-5 computer with 32 GB RAM, a Nvidia GeForce GTX 960 graphic card, Windows 10x64 1809, DxO PhotoLab 2 Elite, ViewPoint 3, Filmpack 5 and the presets from the DxO webpage installed - everything with standard settings. My complete system and all drivers are up to date.

I think the biggest change in PL is the new PhotoLibrary with the search tool. So maybe there is the problem.