Silver Effects filter in Affinity


Can anyone resolve this problem for me: when I open Silver Effects on an image in Affinity Photo 2 from the filer menu, the effects are applied to the whole page, not the image. How do I get it to apply to the image only?


Hello and welcome (though I’m new here too :slight_smile: )

Try “Rasterize and trim” (right click on layer) before invoking Nik. If you have multiple layers, flatten first.

If you need to keep the layers as they are, just create a copy and flatten that and rasterize and trim and use Nik. Then take that image back into your original file as a layer.

You can do all of that in one file without any flattening, but it requires more explanation.


Thank you for the speedy response but, unfortunately, this did not resolve the issue.I wonder if it is a problem on the Affinity side…

If you are able to share the Affinity file, I’ll gladly check for you too. Some other users would likely also be happy to see if they can help.

If you can’t share the file for any reason, good luck and please come back and update if you find a solution.


The forum forbids me from uploading the Affinity file, but if it is of any use to anyone, I attach one of the images I’m working on. It was originally a .tiff, but I converted it to a .jpg using Photo Lab. Any help appreciated.


So upload it to a file sharing service, like Dropbox / WeTransfer / [your favourite] and post the link to it here.

OK, try this… help appreciated.

Just checked … AP2 opens the file *.afphoto, but the Nik filters appeared greyed out.
Exported the file as *.tif and the Nik filter (SilverEfex 6) worked w/o problem.

Ok, not exactly what I pictured but similar. You would need to crop out the white area.

Or easier. Use move tool. Click once on image. Ctrl+C (Cmd+C?) to copy. And create new image from clipboard.

Then work with that.

Oh yeah, sorry, forgot to say I didn’t rasterise the image…, but neither .jpg or .tiff works for me. Thanks anyway Wolfgang.

Still not happening for me, might try a complete uninstall and reinstall of both apps, just incase. Thanks anyway underexposed…

Did you have an adjustment layer selected? A pixel layer must be the active layer before you invoke a NIK filter.

AP2 opens the file *.afphoto, but the Nik filters appeared greyed out.

the reason … Nik works with jpg and tif-files, but not AP’s own format
→ so I had to export …

The following steps are for Windows. Guessing it will be the same in the MAC version. You could also trim away the white area, but I find a quick copy into a new file to often be the simpler approach.

  • Canvas needs to be same size as image.
  • Copy image into new file (copy → new image from clipboard).
  • In the new file Nik will be greyed out.
  • Right click layer and select rasterize.
  • Nik is now available.


Voila…, doable underexposed, and to print, I simply copy and paste to a new A3+ canvas. Thank you for your expertise and to all who responded to this post. Much appreciated.