SILVER EFEX PRO3 AND VIVEZA 3 DO NOT WORK IN ANY Host Application or as a standalone!

SILVER EFEX PRO3 AND VIVEZA 3 do not open in Photoshop, Lightroom, or DXO Photolab 5 or as a standalone. I see others have had this same problem. Has anyone been provided a resolution? I’ve had a ticket open since June 19th and cannot get anyone in support to help. I’ve done everything they requested - submitted a diagnostic report, uninstalled, downloaded and reinstalled 3 times, restarted the PC, nothing helps. They have not responded to me in over a week. Error code I get when trying to open these 2 plugins is “The procedure entry point could not be located in the dynamic link library C:\ProgramFiles\DXO\NikCollection\bin\Silver Efex Pro 3.exe.” I’ve been using Nik Collection since it’s inception by Google and have never had any issues!!

Hi Michael and welcome,

Have you looked in that folder to see if the exe file is there?

Yes, welcome to the forum, Michael.

I’m guessing your issue relates to a new installation of Nik 5 (?) … In which case, your problem may be similar to the issue (and solution) discussed here.

John M

That would be more clear, if the Version Number from the Main package will be similar to the version number of the single applications
so Nik Collection 5 will include SEP5, Viveza5 and so on
:innocent: :smiling_face_with_three_hearts:

Oh, and just a little thing - writing in all capital letters is considered as shouting and just a tad rude :wink:

He may be intentionally shouting.


I checked the folders and the .exe files are there. I tried running the programs with the .exe file and the results are the same. I’ve uninstalled and reinstalled Nik Collection 5 4 times.

Have you tried doing so via the method described in link I provided above ?
It may be that there’s a Registry reference (or similar) that’s not being cleared out, or reset properly, by the standard uninstall process. In any case, it’s surely worth a try.

John M

1 Like

John, your solution worked. Everything now works as it should. Thanks!