Silver Efex Pro (5.0.5) now CRASHES CONSTANTLY

The app has become literally unusable. Maybe one in five times I manage to do an edit that saves properly back to Photoshop or Lightroom.

Clearly, you are very upset. And I certainly can’t comment on why you are having issues with the Nik Collection. But you’ve given us absolutely no details about how you’re using the package and the problems you’re having with it. As to whether it’s a rip off or not, all I can say is the overwhelming majority of users of the Nik collection are not having the difficulties you seem to be having.

Have you been workibg with DxO to resolve your issue? What operating system are you using?


I’m using a Mac. I’ve tried it with Lightroom and Photoshop. It crashes for unknown reasons, again and again. When saving to Lightroom, it will often leave you with an unaltered .tif file — still in color. This has been an issue all the way through the most recent Nik collections, but the latest version of Silver Efex Pro 3 (5.0.5) is literally unusable. Have you tried it?

I am working with the whole Nik collection without any problems and this is on an OLD Late 2012 iMac.
What are you doing exactly. What error message do you get exactly, what OS. Have you been in touch with support, what do they say. Just rambling on will not help.
Can you upload file which you have problems with?

Interesting coincidence: I’m also using a 2012 machine: a maxed-out late 2012 Mac Mini, on Catalina. It’s rock solid. This is quite literally the only app with issues.

(Although I’ve toned down the headline. Let’s see whether support can deal with this.)

Mine is not even maxed-out. Is it just SE you have problems with or all apps within the collection?

That’s the only app I use. So I’m not sure whether it’s collection-wide. Are you also on Catalina?

Yes, also on Catalina. Can you upload a problem file so that we can test?

Here you go. I had just applied a preset when the app crashed, and is this is what was saved to Lightroom. It’s no different from the original file.

Hello visigoth, can you upload the original tiff file - before you applied any changes to it by SE. I would just like to use that tiff and work with SE on it to see what happens.

Dear @visigoth,
maybe you cant test with the “half split research method”

Take one.tiff and test it with SEP > OK or Error
Take one.tiff and test it with CEP > OK or Error
Take two.tiff and test it with SEP > OK or Error
Take two.tiff and test it with CEP > OK or Error

Depending on the test result you get an first idea :smiley:

Happy testing


Unfortunately, I’m making exactly the same experience.
Hope this get’s fixed soon!
I’m using a MaxBook Pro with macOS Monterey 12.5.1, Silver Efex 5.0.5 x64 opening Silver Efex from Lightroom CC 11.5 !

Running Mac OS Monterey on my 2020 MacBook Pro - all the NIK Collection modules crash MOST (but not all the time). I have reported this problem to DXO support several times. The crash is instantaneous. The resulting image also fails to incorporate any of the edits used with the .tif file. I tend to use Viveza, Color Efex and Silver Efex and I am using NIK Collection 5. NIK Collection 4 never crashed. The crashes occur so often that I can no longer use this software.


J’ai eu jusque très récemment quelques désagréments d’export Silver Efex 3 vers Lightroom Classic : soit l’image revenait dans Lightroom non traitée, soit Silver Efex plantait. Les problèmes ont maintenant disparu (Mac OS 12.5.1, Silver Efex 5.0.4, Lightroom 11.5).

The last version of Silver Efex (5.0.5) is more than bad, sometimes crashing every few editing steps. The whole thing on a 24" M1 and DxO PL as host. I hope for a quick fix of the bugs otherwise I will change my workflow with other programmes, also other mothers have beautiful daughters …

1 Like

In Nik’s defence, I wouldnt be surprised if it is at least something to do with Photoshop / OSX. The way that active Windows and switching backwards and forwards between applications is dealt with in Catalina and Big Sur is dreadful. Hidden windows and dialogue boxes, windows and applications that are at foremost and should be active are actually not active and need repeatedly clicking on. If the nature of Nik and other plug ins means that the image needs to be handed off from Photoshop, dealt with, and then handed back - then no wonder problems are happening because the system is so clunky its hard enough to do that manually. Backing this theory up is that Silver Efex doesnt seem to have an issue when used “standalone” rather than a plug in

Im having lots of problems with Silver Efex too recently, when used as a plug in. Catalina, Photoshop 23.2.1, Nik version 5.0.5. Sometimes it does nothing at all when pressing “apply”, most times it starts to do something but then hangs / crashes. If I wait a while and then force quit Silver Efex and go back into Photoshop - sometimes it has worked and I get the result. Sometimes nothing. Ive bought and used this software many times over the years in all its guises, personally and on behalf of businesses from Nik to Google to DXO - and now at the end of 2022 the performance of it is the worst it has ever been and is a clumsy mess. Might have to start looking at alternatives. A sad day.

“literally unusable” to you alone.