Showing picture folder not working anymore

When I search for photos by keyword and then click on “Show Pictures Folder,” suddenly nothing happens. It definitely worked before. What could be causing this?

Meanwhile in tough with Support. But no real progress. I’m just wondering whether my memory is really deceiving me here. Following what I wrote to the support.

When I right-click on a photo in the image browser after a keyword search and select the “Show image folder” menu, nothing happens!
Previously, as I remember it, the image browser switched to the folder containing this photo. As I said, in the image browser.
Now, however, nothing happens. Even if my memory is deceiving me, this menu entry, “Show picture folder”, should have a function.
Which one, apart from the one I remember, is not clear to me. I can’t find anything about this in the online manual either.

If you display a lot of images with a filter and they are in the same folder, the change may not be seen.
Look in folders palette if your folder is well selected.

Thanks for you reply Franky. It’s just that. The results of a search by keyword are displayed in the image browser. E.g. keyword, beach. Then all images with this keyword from different folders are displayed in the browser. Sometimes I want to see in which folder a particular image is. So I select “show picture folder”. The picture browser should then display the contents of the folder in which this photo is located.
At least that’s how I remember it. But that no longer works. Funnily enough, even the support team can’t tell me whether this is supposed to be the case or not.

I just tested but with a Windows version and it works as in your memories.
Mac users will be able to confirm this or not.

1 Like

Thanks for the confirmation Franky. Even after 3 emails and 2 screen videos, support didn’t get it, sigh.

On macOS 14.2.1 and PL 7.2 and 7.4 it works as it should.

Just thinking out loud - do PL have File and Full Disk permissions to access that folder/volume in macOS settings for Integrity and Security?

1 Like

Hi Required and thanks for the confirmation and your suggestion. But it must be something different. PL has full access since ever to this folder.
But I will continue my research in this direction. Perhaps there is some authorization in the system settings that needs to be set. But why this now also affects PL6 speaks against it.

I have just checked and even added all the options for setting access rights. But it still doesn’t work.
One assumption I still have is that it may be due to the folder index. I had rebuilt it. But I don’t know what can be done there.

1 Like

Thanks for the feedback.

Ok let’s think of something else.
Do you have one or multiple monitors?
If you choose to reveal the photo itself instead of its folder, does PL trigger the Finder to show it?

Works with DPL 7.4.0 build 45 on macOS 12.7.3 (Monterey)

…and seems to be independent of default access rights.

To reset application access rights, you can use with the following command:

tccutil reset All

1 Like

Yes, 2nd monitor. And yes, revealing in finder works. But that is more complicated.
Previously, as already mentioned, the folder content was then displayed in the photo browser.

Thanks platypus, will try this.

“Successfully reset All”, but still not working.

I was testing on macOS 12 on an Intel iMac 2019.
Maybe DPL doesn’t play nice on macOS 13…

And if you disconnect the second monitor.
Any change in result for view of folder in the browser?

Yes maybe. However, I have had Ventura installed for quite a while.
I’ll test it on other computers tomorrow.

No difference.

1 Like