Show Masks Feature

I use PL5 Elite on a Windows 10 PC. When I am using Masks, ie with control lines or with control points, or any local adjustment, I am unable to find the show Mask Feature which is suppose to be located just below the image to the right. Can someone please tell me where it is, or how to turn it on. It would be so helpful to me when editing images, as anyone who uses the feature knows. Also, no create new mask feature there either. Interesting??

That feature is only displayed in the Mac version. To see the masks use the M key which does the same thing.


1 Like

When using the M I often run into a situation that I cannot return back to normal view. M does not toggle on and off - only on. What is the correct way to leave the “show mask”.
Should I re-install my PL5 Elite to fix possible bug.

Thanks Mark,
I have the same issue that Klaus has. I can toggle it on, but not off. I would appreciate knowing the correct way to get out of the show mask. Also, I assume that on windows the only way to add a new mask is to???

No problem here to toggle the different mask views on and off with M
– as long the mouse is over the picture.


Still not working correctly, even with mouse over the image. I think I may start a trouble ticket and see if there is a simple fix. Thanks.

I’ve never had a problem toggling the masks on and with the M key


Shut down PL5 and restarted. Tried a different image, and it now works. Thank you everyone for your assistance and patience.

1 Like

Strange things like that have been known to occur if PL has been left active but idling (with no input from you) for quite a while … such as leaving it running while you go off and do something else, for an hour or two ! - - - Might that have been the case ?

John M

I’ve run into the same issue as Klaus and SailAway.

  1. If I open PL5 (with an image never edited before) and add a Control Point or Control Line (and place the dropper in this latter case) then I can toggle the mask on and off repeatedly with the “M” key without any problem.
  2. If I then make a change via the Local Adjustments pallete to any of Chroma / Luma / Opacity the “M” key then ceases to have any effect. If the mask was on it remains on, and if off it remains off, despite repeatedly entering “M”.
  3. If I then click on the Control Point / Control Line position marker, the “M” key then resumes operating as expected to turn the mask on and off.
  4. If I then make a further change to via the Local Adjustments pallete to any of Chroma / Luma / Opacity the “M” key then ceases to have any effect again.

I can cycle around steps 3 and 4 repeatedly with the same result. It’s as though once one of the the Local Adjustment palette controls has been used PL5 ceases to monitor for the “M” key mask display control.

I’d suggest it’s a fault. I’d noticed this in the past but never really explored the matter until prompted by this thread. I’ll raise a support ticket.

1 Like

Oh, Please do SAFCO1. What you described is exactly what I experienced. Thanks.

Done - I’ll post any updates here.

This is not truly a fault.

When you interact with the palettes, input focus is taken away from the editing window - and vice versa. This kind of thing is quite common in other software and is there to avoid mis-interpreting a keystroke when in an inappropriate part of the UI.

All you need to do is direct focus back the the editing window by clicking in it somewhere, as you have found.

I can understand the point you are making when you say it is not truly a fault, and you are correct in saying that clicking anywhere in the editing window will do to resume the “M” key mask on / off control working. (I emphasise clicking, as simply having the mouse cursor positioned over the editing window is not sufficient).

However, given that the behaviour causes confusion to me and to others I’d suggest it’s still worth raising with DxO (as I’ve done) to see if they have any ideas to address this.

Of course, if we Windows users had a Mask On / Mask Off button as found with the Mac version of PL then the issue wouldn’t arise :joy:.

1 Like

That’s as may be but, as I said, PL is not the only app to implement this behaviour. Changing it could well disable future improvements like pressing ‘M’, ‘H’, ‘S’ to set focus in the palettes to something like mid-tone, highlight or shadow.

It’s always worth asking.

You need to rattle @StevenL’s cage - he’s the king of Win/Mac differences

This is common/standard Windows behaviour - aka “Hey you, do this” … As noted by Joanna, an object first needs to have focus directed to it before it can understand that some action is intended for it.

It’s the same for sliders; you can change a slider’s value by clicking on it and then use arrow-keys … but, if focus is then directed somewhere else (say by clicking on something else) then you will need to click back on the slider before it can receive more arrow-key input.

Yes, that would change the behaviour - as directing focus and activating the Mask would then be one and the same action.

John M


I understand the point you are making and in general I can see you are correct.

I think some of the confusion arises because it feels like you are only doing one thing - i.e. making a Local Adjustment.

  • You select Local Adjustments in the menu at the top of the image (or by selecting Tool in the Local Adjustments palette).
  • You then choose the adjustment such as a Control Point and position it - at this point you can toggle the mask on/off with “M”
  • You then make one or more adjustments via the Equaliser - you can still toggle the mask on/off
  • You then decide you want to refine the mask and adjust one or more of the Chroma / Luma / Opacity settings in the Local Adjustments palette - now you can’t toggle the mask on / off, unless you first click back on the image.

I understand that adjusting a Local Adjustment palette setting moves the “focus” away from the image, and can see how clicking on the image refocuses, and hence “M” works again. However, I can equally see why I and others are a little confused or surprised by the behaviour. Once you realise how it’s working it’s no big deal to remember to click back on the image, but I suspect the users above will not be the last ones to be confused by this behaviour.

1 Like

Hi @SAFC01
Thanks for your feedback.

Your comment highlights something that could be improved for a better workflow.
Besides the fact of having “that bar w/ the Show Mask button” (we are aware of this shortcoming on the Windows version), being able to toggle the mask on/off, even when you have moved the focus on the luma/chroma sliders, should be available for the user.



Thanks for your message. As I said, it’s not a big deal but I’m sure it will continue to catch new users out if left as it is.

I said I’d provide any updates from my support ticket with DxO on this topic.

I received a reply today which confirmed the statement of others that it’s a matter of “losing focus”, which is returned if you click somewhere on the image.

In line with Steven’s comments above, they said they’ll pass my comments on to the developers. Let’s see what happens.