Setting colours in Photolab &

OS : Windows 11. I have a problem between Photolab 6 compared to Photolab 5.
In Photoloab 5 in the “Preferences” I have a field: (ICC profile used for display) which allows me some options: I chose “Generic profile sRGB - for display”. This choice shows me the images arw (Sony raw) loaded correctly concerning colours.

In Photolab 6 in the “Preferences” the item “ICC profile used for display” DOESN’T really exist. All the arw images (Sony raw) loaded have a notable dominant “Magenta” of which I have already speech which makes it impossible to work with Photolab 6. Do you have any suggestions for all of this?

The ICC profiles are now applied using the new Soft Proofing feature in the Color palette.


Besides soft proofing: be attentive to what the working color space is set to (it’s a new setting in the Color tab - you won’t see it if you migrated a custom workspace from PL5). If you use DxO Wide Gamut as your working color space (you should, most of the time), then check your settings in the Color Rendering palette. See if raising “Protect saturated colors” helps or if changing some of the other rendering options gives a better and more consistent rendition.

1 Like

If you have not calibrated your screen then I would highly recommend doing so with a proper colorimeter. Once you have calibrated your screen you will have a profile for your screen which is set in Windows. PL will use that profile for your display.

If your screen has a higher gamut than your final output you would need to check the softproofing to simulate what your final output would look like using a profile of your output - normally sRGB for web viewing.

That’s where the buggar went, thank you!

I tried to solve the problem of the dominant “Magenta” present on all my images loaded on PL6. And not present at all on PL5.

On PL5 in Preferences/Dsiplay I set “Generic Profile (sRGB) for display device”. And all pictures are ok.

On PL6, since in Preferences/display, there is no longer the field where to set the color profile, I set
in Working color space: DxO Wide Gamut

in Soft Proofing: sRGB Color Space Profile or sRGB IEC61966-2.1 with no difference between the two

Now with these settings all the raw photos I upload have a dominant magenta totally absent in PL5.

Since I don’t understand which color profile loads PL5 with the wording “Generic Profile (sRGB) for display device” and since I don’t have this color profile to load from the ICC profile archive, I really don’t know how to proceed.

In fact, and with great regret, I continue to use only PL5 which works perfectly
Does anyone know why this happens and how to fix it?

@Paolo1 could you post a RAW file either here if it is small enough or via some file sharing service so we can take a look and help you find a solution.

Also please provide a screenshot from both PL5 and PL6 so we can see your issue.

Thanks :slightly_smiling_face:

Have you opened a support ticket for this?


perhaps I managed to send both the raw format and the two screenshots of PL5 and PL6 which also show the different histograms.
Thank you
DSC07752.ARW (47,1 MB)

I think the problem might be that in V5 you are choosing a generic sRGB profile while in V6 DXO is using, as all colour managed programs should use, the colour profile for your monitor registered in Windows

Try setting the display profile to “current profile of the display device” and see if that gives the same result as V6?


Yes, that sounds plausible

calibrated screen (sRGB, 6500K, grey balanced) – pic shown with “1-DxO Standard”
(shown in PL6.3.1_134)

and no pinkish appearance with other calibrations.

I understand the problem but the color profile that windows uses (as you can see from the attachment) is that of my monitor. (Samsung-natural color Pro 1.0 ICM. Now in PL6 this setting is not detected even going to set this profile in soft proofing image by image, always showing the same “magenta” cast.
windows settings.pdf (77,0 KB)

All applications will use the Samsung monitor profile for colour management and V5 gives you this option. In V6 it defaults to the Samsung profile to avoid confusion, as most programs do… You are choosing to use a different profile in DXO V5 (generic sRGB). So V5 and V6 are using different colour pipelines and I think this is the root cause of your issues.

1 Like

Unfortunately, after countless attempts, I can’t explain why PL5 works perfectly in color vision while PL6 does NOT work and does not change its dominant “Magenta” with any setting, forcing me to use only PL5.

Did you try changing the monitor profile in V5 from sRGB to the actual monitor profile?

1 Like

as @IanS said, please use
Screen Shot 02-17-23 at 05.34 PM
in PL5.8.0_4838 – and NOT the Generic sRGB.

THEN using the same display profile the result should be the same.

calibrated screen (sRGB, 6500K, grey balanced) – pic shown with “1-DxO Standard”

yes, in PL5 I set this profile. But PL5 works already properly, it is PL& that changes colours

I prefer not to change the color profile in PL5 which works perfectly nor change anything in windows 11.
Unfortunately it’s PL6 which doesn’t work well

I tried your RAW file with the no correction preset and with my own regular preset. I’m not seeing any magenta cast in PL 6.3.1 (Windows). This does seem to be a color management problem on your computer.

Please make sure that you don’t have a filter set in the fx tab (FilmPack adjustments).

Are you using multiple monitors having different ICC profiles in Windows?

With all due respect, Egregius has found no problem with V6 and I have loaded your file into both V5 and V6 and the screen shots are below. This is not a problem with V6 it is simply a setting you have inadvertently made or it is the colour profile issue which you haven’t actually checked.